summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/ChangeLog8
-rw-r--r--dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild28
2 files changed, 20 insertions, 16 deletions
diff --git a/dev-util/codeblocks/ChangeLog b/dev-util/codeblocks/ChangeLog
index 6eadc6b64805..89c367789439 100644
--- a/dev-util/codeblocks/ChangeLog
+++ b/dev-util/codeblocks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/codeblocks
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.11 2007/12/22 01:45:39 jurek Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.12 2008/01/30 23:39:21 jurek Exp $
+
+ 30 Jan 2008; Jurek Bartuszek <jurek@gentoo.org>
+ codeblocks-1.0_pre20071215.ebuild:
+ Minor fixes and changes (bug #199843)
22 Dec 2007; Jurek Bartuszek <jurek@gentoo.org>
-codeblocks-1.0_pre20070124.ebuild, -codeblocks-1.0_pre20070404.ebuild,
diff --git a/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild b/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
index e8e63117c8e1..bb2d0e6547a5 100644
--- a/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
+++ b/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild,v 1.1 2007/12/15 12:26:29 jurek Exp $
-
-inherit eutils autotools wxwidgets
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild,v 1.2 2008/01/30 23:39:21 jurek Exp $
#needed for wxwidgets.eclass
WX_GTK_VER="2.8"
+inherit eutils autotools wxwidgets
+
DESCRIPTION="Code::Blocks - a free cross-platform C/C++ IDE"
HOMEPAGE="http://www.codeblocks.org/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
@@ -14,7 +14,7 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="unicode contrib debug"
+IUSE="contrib debug"
RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*"
@@ -24,15 +24,15 @@ DEPEND="${RDEPEND}
>=sys-devel/libtool-1.4
app-arch/zip"
-pkg_setup() {
- if use unicode; then
- #check for gtk2-unicode
- need-wxwidgets unicode
- else
- #check for gtk2-ansi
- need-wxwidgets gtk2
- fi
-}
+#pkg_setup() {
+# if use unicode; then
+# #check for gtk2-unicode
+# need-wxwidgets unicode
+# else
+# #check for gtk2-ansi
+# need-wxwidgets gtk2
+# fi
+#}
src_compile() {
export WANT_AUTOCONF=2.5