summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog5
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index 19cdaeb0d2ce..2460b58fff01 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/wsgiintercept
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.16 2015/05/29 03:42:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.17 2015/06/02 16:01:58 idella4 Exp $
+
+ 02 Jun 2015; Ian Delaney <idella4@gentoo.org> wsgiintercept-0.10.0.ebuild:
+ Disable tests connecting to the network, fixes Bug #550710
*wsgiintercept-0.10.0 (29 May 2015)
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild
index 81b1c18a31a3..422ad023665d 100644
--- a/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild
+++ b/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild,v 1.1 2015/05/29 03:42:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild,v 1.2 2015/06/02 16:01:58 idella4 Exp $
EAPI=5
@@ -33,6 +33,11 @@ S="${WORKDIR}/${MY_P}"
python_prepare_all() {
# .pyc files cause failure of tests
rm -rf test/__pycache__/ || die
+
+ # Disable tests connecting to the network; Bug #550710
+ sed -e 's:test_http_not_intercepted:_&:' \
+ -e 's:test_https_not_intercepted:_&:' \
+ -i test/{test_urllib.py,test_http_client.py,test_requests.py} || die
distutils-r1_python_prepare_all
}