summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/phpdbg/ChangeLog5
-rw-r--r--dev-php4/phpdbg/Manifest6
-rw-r--r--dev-php4/phpdbg/phpdbg-2.11.32.ebuild41
3 files changed, 30 insertions, 22 deletions
diff --git a/dev-php4/phpdbg/ChangeLog b/dev-php4/phpdbg/ChangeLog
index a523f4c296b9..96204b9094a4 100644
--- a/dev-php4/phpdbg/ChangeLog
+++ b/dev-php4/phpdbg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php4/phpdbg
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/ChangeLog,v 1.3 2005/11/19 20:52:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/ChangeLog,v 1.4 2005/11/25 15:49:56 chtekk Exp $
+
+ 25 Nov 2005; Luca Longinotti <chtekk@gentoo.org> phpdbg-2.11.32.ebuild:
+ Fix var ordering, tidy up ebuild.
19 Nov 2005; Markus Rothe <corsair@gentoo.org> phpdbg-2.11.32.ebuild:
Added ~ppc64 keyword; bug #102649
diff --git a/dev-php4/phpdbg/Manifest b/dev-php4/phpdbg/Manifest
index 619a6bf77fa2..342d0b2a88c4 100644
--- a/dev-php4/phpdbg/Manifest
+++ b/dev-php4/phpdbg/Manifest
@@ -1,4 +1,4 @@
-MD5 91f770456f10f38004c7724c5cd46b61 ChangeLog 507
-MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
-MD5 0f786f44dfc221a7973ca34fadc19680 phpdbg-2.11.32.ebuild 1492
+MD5 1e10b38cd40b4f3ee0324e88e3dab044 ChangeLog 618
MD5 4f8b7e495c942a2fc4eb4722d0b2382d files/digest-phpdbg-2.11.32 66
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+MD5 9336342f65f084aa6f122016726d1b74 phpdbg-2.11.32.ebuild 1439
diff --git a/dev-php4/phpdbg/phpdbg-2.11.32.ebuild b/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
index 2f9bb3cd69d3..10a428d8d819 100644
--- a/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
+++ b/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
@@ -1,49 +1,54 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/phpdbg-2.11.32.ebuild,v 1.3 2005/11/19 20:52:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/phpdbg-2.11.32.ebuild,v 1.4 2005/11/25 15:49:56 chtekk Exp $
PHP_EXT_NAME="dbg"
+PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
+
inherit php-ext-source-r1
-IUSE=""
-S="${WORKDIR}/dbg-${PV}${PL}"
+
+KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
DESCRIPTION="A PHP debugger useable with some editors like phpedit."
-SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}${PL}-src.tar.gz"
HOMEPAGE="http://dd.cron.ru/dbg/"
LICENSE="dbgphp"
SLOT="0"
+IUSE=""
-KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
+MY_P="dbg-${PV}${PL}"
+SRC_URI="mirror://sourceforge/dbg2/${MY_P}-src.tar.gz"
+S="${WORKDIR}/${MY_P}"
need_php_by_category
src_compile() {
- # phpdbg does not work with Zend Thread Safety (ZTS)
- # so abort if we are using PHP compiled with ZTS.
- if has_zts ; then
- eerror "phpdbg doesn't work with a ZTS enabled PHP."
- eerror "Please disable ZTS by turning the 'threads'"
- eerror "USE flag off when you compile dev-lang/php."
- die "phpdbg does not support ZTS"
- fi
+ has_php
+
+ # phpdbg does not work with Zend Thread Safety (ZTS)
+ # so abort if we are using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "phpdbg doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "phpdbg does not support ZTS"
+ fi
my_conf="--enable-dbg=shared --with-dbg-profiler"
php-ext-source-r1_src_compile
}
-src_install () {
+src_install() {
php-ext-source-r1_src_install
- dodoc AUTHORS COPYING INSTALL
+ dodoc-php AUTHORS COPYING INSTALL
php-ext-base-r1_addtoinifiles "[Debugger]"
php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
}
pkg_postinst() {
- einfo "Please reload Apache to activate the changes"
+ einfo "Please reload Apache to activate the changes."
}
pkg_postrm() {
- einfo "You need to remove all lines referring to the debugger, and"
- einfo "extension=dbg.so. Please reload Apache to activate the changes."
+ einfo "Please reload Apache to activate the changes."
}