summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/boost-1.55.0-r2.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 94906743eb2c..ae1b4f05a231 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.328 2014/08/14 08:44:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.329 2014/08/14 08:52:11 pinkbyte Exp $
+
+ 14 Aug 2014; Sergey Popov <pinkbyte@gentoo.org> boost-1.55.0-r2.ebuild:
+ Add proper blocker for app-emulation/emul-linux-x86-cpplibs, wrt bug #519744,
+ inherit multilib eclass explicitly
14 Aug 2014; Sergey Popov <pinkbyte@gentoo.org> boost-1.52.0-r7.ebuild,
boost-1.53.0-r1.ebuild, boost-1.54.0-r1.ebuild, boost-1.55.0-r1.ebuild,
diff --git a/dev-libs/boost/boost-1.55.0-r2.ebuild b/dev-libs/boost/boost-1.55.0-r2.ebuild
index 7aebfcb4bdb7..2f7983375076 100644
--- a/dev-libs/boost/boost-1.55.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.55.0-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.55.0-r2.ebuild,v 1.2 2014/08/14 08:44:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.55.0-r2.ebuild,v 1.3 2014/08/14 08:52:11 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-inherit eutils flag-o-matic multiprocessing python-r1 toolchain-funcs versionator multilib-minimal
+inherit eutils flag-o-matic multilib multiprocessing python-r1 toolchain-funcs versionator multilib-minimal
MY_P="${PN}_$(replace_all_version_separators _)"
MAJOR_V="$(get_version_component_range 1-2)"
@@ -20,7 +20,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
IUSE="context debug doc icu +nls mpi python static-libs +threads tools"
-RDEPEND="icu? ( >=dev-libs/icu-3.6:=[${MULTILIB_USEDEP}] )
+RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-cpplibs[-abi_x86_32(-)] )
+ icu? ( >=dev-libs/icu-3.6:=[${MULTILIB_USEDEP}] )
!icu? ( virtual/libiconv[${MULTILIB_USEDEP}] )
mpi? ( || ( sys-cluster/openmpi[cxx] sys-cluster/mpich2[cxx,threads] ) )
python? ( ${PYTHON_DEPS} )