summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/ChangeLog7
-rw-r--r--dev-libs/protobuf/protobuf-2.4.0a.ebuild126
-rw-r--r--dev-libs/protobuf/protobuf-2.5.0-r1.ebuild124
-rw-r--r--dev-libs/protobuf/protobuf-2.5.0.ebuild122
-rw-r--r--dev-libs/protobuf/protobuf-2.6.0.ebuild126
-rw-r--r--dev-libs/protobuf/protobuf-2.6.1-r1.ebuild133
-rw-r--r--dev-libs/protobuf/protobuf-2.6.1-r2.ebuild157
-rw-r--r--dev-libs/protobuf/protobuf-2.6.1.ebuild126
8 files changed, 6 insertions, 915 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index 6815aa84407f..697d8ed949ef 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.83 2015/04/25 11:53:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.84 2015/05/04 03:22:45 radhermit Exp $
+
+ 04 May 2015; Tim Harder <radhermit@gentoo.org> -protobuf-2.4.0a.ebuild,
+ -protobuf-2.5.0.ebuild, -protobuf-2.5.0-r1.ebuild, -protobuf-2.6.0.ebuild,
+ -protobuf-2.6.1.ebuild, -protobuf-2.6.1-r1.ebuild, -protobuf-2.6.1-r2.ebuild:
+ Remove old.
25 Apr 2015; Jeroen Roovers <jer@gentoo.org> protobuf-2.6.1-r3.ebuild:
Marked ~ppc64 too.
diff --git a/dev-libs/protobuf/protobuf-2.4.0a.ebuild b/dev-libs/protobuf/protobuf-2.4.0a.ebuild
deleted file mode 100644
index 0c0aac126928..000000000000
--- a/dev-libs/protobuf/protobuf-2.4.0a.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.4.0a.ebuild,v 1.10 2014/08/14 00:03:40 jer Exp $
-
-EAPI="3"
-
-JAVA_PKG_IUSE="source"
-PYTHON_DEPEND="python? 2"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit autotools eutils distutils java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/"
-SRC_URI="http://protobuf.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 -hppa ppc ppc64 x86 ~x64-macos"
-IUSE="emacs examples java python static-libs vim-syntax"
-
-DEPEND="${DEPEND} java? ( >=virtual/jdk-1.5 )
- python? ( dev-python/setuptools )
- emacs? ( virtual/emacs )"
-RDEPEND="${RDEPEND} java? ( >=virtual/jre-1.5 )
- emacs? ( virtual/emacs )"
-
-DISTUTILS_SETUP_FILES=("python|setup.py")
-PYTHON_MODNAME="google/protobuf"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
- use java && java-pkg-opt-2_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
- eautoreconf
-
- if use python; then
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use python; then
- einfo "Compiling Python library ..."
- distutils_src_compile
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd
- jar cf "${PN}.jar" -C java/build . || die "jar failed"
- fi
-
- if use emacs; then
- elisp-compile "${S}/editors/protobuf-mode.el" || die "elisp-compile failed!"
- fi
-}
-
-src_test() {
- emake check || die "emake check failed"
-
- if use python; then
- distutils_src_test
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGES.txt CONTRIBUTORS.txt README.txt
-
- use static-libs || rm -rf "${D}"/usr/lib*/*.la
-
- if use python; then
- distutils_src_install
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}/proto.vim"
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}/70${PN}-gentoo.el"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "doins examples failed"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use python && distutils_pkg_postrm
-}
diff --git a/dev-libs/protobuf/protobuf-2.5.0-r1.ebuild b/dev-libs/protobuf/protobuf-2.5.0-r1.ebuild
deleted file mode 100644
index 2045e7218f46..000000000000
--- a/dev-libs/protobuf/protobuf-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0-r1.ebuild,v 1.4 2015/04/08 17:51:55 mgorny Exp $
-
-EAPI=5
-JAVA_PKG_IUSE="source"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/"
-SRC_URI="http://protobuf.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0/8" # subslot = soname major version
-KEYWORDS="amd64 ~arm -hppa ~ia64 ~mips -ppc -ppc64 x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="emacs examples java python static-libs vim-syntax"
-
-CDEPEND="emacs? ( virtual/emacs )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-src_prepare() {
- append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
-
- epatch "${FILESDIR}"/${P}-x32.patch
- if [[ ${CHOST} != *-darwin* ]] ; then
- # breaks Darwin, bug #472514
- epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
- eautoreconf
- fi
-
- if use python; then
- cd python && distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use python; then
- einfo "Compiling Python library ..."
- pushd python >/dev/null
- distutils-r1_src_compile
- popd >/dev/null
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java >/dev/null
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd >/dev/null
- jar cf ${PN}.jar -C java/build . || die "jar failed"
- fi
-
- if use emacs; then
- elisp-compile "${S}"/editors/protobuf-mode.el
- fi
-}
-
-src_test() {
- emake check
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_test
- popd >/dev/null
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc CHANGES.txt CONTRIBUTORS.txt README.txt
- prune_libtool_files
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_install
- popd >/dev/null
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}"/proto.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el*
- elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
- fi
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-libs/protobuf/protobuf-2.5.0.ebuild b/dev-libs/protobuf/protobuf-2.5.0.ebuild
deleted file mode 100644
index 2460214a8bfa..000000000000
--- a/dev-libs/protobuf/protobuf-2.5.0.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0.ebuild,v 1.14 2015/04/08 17:51:55 mgorny Exp $
-
-EAPI=5
-JAVA_PKG_IUSE="source"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools eutils distutils-r1 java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/"
-SRC_URI="http://protobuf.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0/8" # subslot = soname major version
-KEYWORDS="amd64 arm -hppa ~ia64 ~mips -ppc -ppc64 x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos x86-macos"
-IUSE="emacs examples java python static-libs vim-syntax"
-
-CDEPEND="emacs? ( virtual/emacs )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-x32.patch
- if [[ ${CHOST} != *-darwin* ]] ; then
- # breaks Darwin, bug #472514
- epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
- eautoreconf
- fi
-
- if use python; then
- cd python && distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use python; then
- einfo "Compiling Python library ..."
- pushd python >/dev/null
- distutils-r1_src_compile
- popd >/dev/null
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java >/dev/null
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd >/dev/null
- jar cf ${PN}.jar -C java/build . || die "jar failed"
- fi
-
- if use emacs; then
- elisp-compile "${S}"/editors/protobuf-mode.el
- fi
-}
-
-src_test() {
- emake check
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_test
- popd >/dev/null
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc CHANGES.txt CONTRIBUTORS.txt README.txt
- prune_libtool_files
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_install
- popd >/dev/null
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}"/proto.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el*
- elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
- fi
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-libs/protobuf/protobuf-2.6.0.ebuild b/dev-libs/protobuf/protobuf-2.6.0.ebuild
deleted file mode 100644
index ab54cba250d3..000000000000
--- a/dev-libs/protobuf/protobuf-2.6.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.6.0.ebuild,v 1.5 2014/10/10 20:17:24 maekke Exp $
-
-EAPI=5
-JAVA_PKG_IUSE="source"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/ https://github.com/google/protobuf/"
-SRC_URI="https://protobuf.googlecode.com/svn/rc/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0/9" # subslot = soname major version
-KEYWORDS="~amd64 ~arm -hppa ~mips -ppc -ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="emacs examples java python static-libs vim-syntax"
-
-CDEPEND="emacs? ( virtual/emacs )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )
- python? (
- dev-python/google-apputils[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-src_prepare() {
- append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
-
- if [[ ${CHOST} != *-darwin* ]] ; then
- # breaks Darwin, bug #472514
- epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
- eautoreconf
- fi
-
- if use python; then
- cd python && distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use python; then
- einfo "Compiling Python library ..."
- pushd python >/dev/null
- distutils-r1_src_compile
- popd >/dev/null
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java >/dev/null
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd >/dev/null
- jar cf ${PN}.jar -C java/build . || die "jar failed"
- fi
-
- if use emacs; then
- elisp-compile "${S}"/editors/protobuf-mode.el
- fi
-}
-
-src_test() {
- emake check
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_test
- popd >/dev/null
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc CHANGES.txt CONTRIBUTORS.txt README.txt
- prune_libtool_files
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_install
- popd >/dev/null
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}"/proto.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el*
- elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
- fi
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-libs/protobuf/protobuf-2.6.1-r1.ebuild b/dev-libs/protobuf/protobuf-2.6.1-r1.ebuild
deleted file mode 100644
index 05c33fc80c8e..000000000000
--- a/dev-libs/protobuf/protobuf-2.6.1-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.6.1-r1.ebuild,v 1.4 2014/11/28 16:53:11 radhermit Exp $
-
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-JAVA_PKG_IUSE="source"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools-multilib eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/ https://github.com/google/protobuf/"
-SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0/9" # subslot = soname major version
-KEYWORDS="~amd64 ~arm -hppa ~mips -ppc -ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="emacs examples java python static-libs vim-syntax"
-
-CDEPEND="emacs? ( virtual/emacs )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )
- python? (
- dev-python/google-apputils[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-src_prepare() {
- append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
-
- # breaks Darwin, bug #472514
- [[ ${CHOST} != *-darwin* ]] && epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
-
- # fix build with emacs-24.4 (bug #524100)
- epatch "${FILESDIR}"/${PN}-2.5.0-emacs-24.4.patch
-
- autotools-multilib_src_prepare
-
- if use python; then
- cd python && distutils-r1_src_prepare
- fi
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi; then
- if use python; then
- einfo "Compiling Python library ..."
- pushd "${S}"/python >/dev/null
- PROTOC="${BUILD_DIR}"/src/protoc distutils-r1_src_compile
- popd >/dev/null
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- pushd "${S}" >/dev/null
- "${BUILD_DIR}"/src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java >/dev/null
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd >/dev/null
- jar cf ${PN}.jar -C java/build . || die "jar failed"
- popd >/dev/null
- fi
- fi
-}
-
-src_compile() {
- autotools-multilib_src_compile
-
- if use emacs; then
- elisp-compile "${S}"/editors/protobuf-mode.el
- fi
-}
-
-src_test() {
- autotools-multilib_src_test check
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_test
- popd >/dev/null
- fi
-}
-
-src_install() {
- autotools-multilib_src_install
-
- dodoc CHANGES.txt CONTRIBUTORS.txt README.md
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_install
- popd >/dev/null
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}"/proto.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el*
- elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
- fi
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild b/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild
deleted file mode 100644
index 466373ed83f5..000000000000
--- a/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild,v 1.3 2015/03/10 17:58:44 vapier Exp $
-
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-JAVA_PKG_IUSE="source"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools-multilib eutils flag-o-matic toolchain-funcs distutils-r1 java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/ https://github.com/google/protobuf/"
-SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0/9" # subslot = soname major version
-KEYWORDS="~amd64 ~arm ~arm64 -hppa ~ia64 ~mips -ppc -ppc64 ~sh ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="emacs examples java python static-libs vim-syntax zlib"
-
-CDEPEND="emacs? ( virtual/emacs )
- python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )
- python? (
- dev-python/google-apputils[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-src_prepare() {
- append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
-
- # breaks Darwin, bug #472514
- [[ ${CHOST} != *-darwin* ]] && epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
-
- # fix build with emacs-24.4 (bug #524100)
- epatch "${FILESDIR}"/${PN}-2.5.0-emacs-24.4.patch
-
- autotools-multilib_src_prepare
-
- if use python; then
- cd python && distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with zlib)
- )
-
- if tc-is-cross-compiler; then
- # The build system wants `protoc` when building, so we need a copy that
- # runs on the host. This is more hermetic than relying on the version
- # installed in the host being the exact same version.
- mkdir -p "${WORKDIR}"/build || die
- pushd "${WORKDIR}"/build >/dev/null
- ECONF_SOURCE=${S} econf_build "${myeconfargs[@]}"
- myeconfargs+=( --with-protoc="${PWD}"/src/protoc )
- popd >/dev/null
- fi
-
- autotools-multilib_src_configure
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi; then
- if use python; then
- einfo "Compiling Python library ..."
- pushd "${S}"/python >/dev/null
- PROTOC="${BUILD_DIR}"/src/protoc distutils-r1_src_compile
- popd >/dev/null
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- pushd "${S}" >/dev/null
- "${BUILD_DIR}"/src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java >/dev/null
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd >/dev/null
- jar cf ${PN}.jar -C java/build . || die "jar failed"
- popd >/dev/null
- fi
- fi
-}
-
-src_compile() {
- if tc-is-cross-compiler; then
- emake -C "${WORKDIR}"/build/src protoc
- fi
-
- autotools-multilib_src_compile
-
- if use emacs; then
- elisp-compile "${S}"/editors/protobuf-mode.el
- fi
-}
-
-src_test() {
- autotools-multilib_src_test check
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_test
- popd >/dev/null
- fi
-}
-
-src_install() {
- autotools-multilib_src_install
-
- dodoc CHANGES.txt CONTRIBUTORS.txt README.md
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_install
- popd >/dev/null
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}"/proto.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el*
- elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
- fi
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-libs/protobuf/protobuf-2.6.1.ebuild b/dev-libs/protobuf/protobuf-2.6.1.ebuild
deleted file mode 100644
index 1912d5d390f5..000000000000
--- a/dev-libs/protobuf/protobuf-2.6.1.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.6.1.ebuild,v 1.1 2014/10/31 00:43:41 radhermit Exp $
-
-EAPI=5
-JAVA_PKG_IUSE="source"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
-
-DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
-HOMEPAGE="http://code.google.com/p/protobuf/ https://github.com/google/protobuf/"
-SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0/9" # subslot = soname major version
-KEYWORDS="~amd64 ~arm -hppa ~mips -ppc -ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="emacs examples java python static-libs vim-syntax"
-
-CDEPEND="emacs? ( virtual/emacs )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.5 )
- python? (
- dev-python/google-apputils[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-src_prepare() {
- append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
-
- if [[ ${CHOST} != *-darwin* ]] ; then
- # breaks Darwin, bug #472514
- epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
- eautoreconf
- fi
-
- if use python; then
- cd python && distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use python; then
- einfo "Compiling Python library ..."
- pushd python >/dev/null
- distutils-r1_src_compile
- popd >/dev/null
- fi
-
- if use java; then
- einfo "Compiling Java library ..."
- src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
- mkdir java/build
- pushd java/src/main/java >/dev/null
- ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
- popd >/dev/null
- jar cf ${PN}.jar -C java/build . || die "jar failed"
- fi
-
- if use emacs; then
- elisp-compile "${S}"/editors/protobuf-mode.el
- fi
-}
-
-src_test() {
- emake check
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_test
- popd >/dev/null
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc CHANGES.txt CONTRIBUTORS.txt README.md
- prune_libtool_files
-
- if use python; then
- pushd python >/dev/null
- distutils-r1_src_install
- popd >/dev/null
- fi
-
- if use java; then
- java-pkg_dojar ${PN}.jar
- use source && java-pkg_dosrc java/src/main/java/*
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins editors/proto.vim
- insinto /usr/share/vim/vimfiles/ftdetect/
- doins "${FILESDIR}"/proto.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} editors/protobuf-mode.el*
- elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
- fi
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}