summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/grantlee/grantlee-0.1.7.ebuild')
-rw-r--r--dev-libs/grantlee/grantlee-0.1.7.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/grantlee/grantlee-0.1.7.ebuild b/dev-libs/grantlee/grantlee-0.1.7.ebuild
new file mode 100644
index 000000000000..cca3e5be6546
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-0.1.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.1.7.ebuild,v 1.1 2011/04/25 11:44:59 tampakrap Exp $
+
+EAPI=3
+
+inherit cmake-utils
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="http://www.gitorious.org/grantlee/pages/Home"
+SRC_URI="http://www.loegria.net/grantlee/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc test"
+
+COMMON_DEPEND="
+ >=x11-libs/qt-core-4.5.0:4
+ >=x11-libs/qt-gui-4.5.0:4
+ >=x11-libs/qt-script-4.5.0:4
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[-nodot] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=(AUTHORS CHANGELOG GOALS README)
+
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${CMAKE_BUILD_DIR}/apidox/")
+
+ cmake-utils_src_install
+}