summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/hugs98/hugs98-2005.3-r2.ebuild')
-rw-r--r--dev-lang/hugs98/hugs98-2005.3-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/hugs98/hugs98-2005.3-r2.ebuild b/dev-lang/hugs98/hugs98-2005.3-r2.ebuild
index 972ea5b28941..e9e230f062e4 100644
--- a/dev-lang/hugs98/hugs98-2005.3-r2.ebuild
+++ b/dev-lang/hugs98/hugs98-2005.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2005.3-r2.ebuild,v 1.17 2006/09/12 00:32:17 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2005.3-r2.ebuild,v 1.18 2006/10/03 23:21:46 dcoutts Exp $
inherit base flag-o-matic eutils versionator multilib
@@ -46,7 +46,7 @@ RDEPEND="
opengl? ( virtual/opengl virtual/glu virtual/glut )
openal? ( media-libs/openal )"
DEPEND="${RDEPEND}
- opengl? ( x11-base/opengl-update )
+ opengl? ( app-admin/eselect-opengl )
~app-text/docbook-sgml-dtd-4.2"
# the testsuite is not included in the tarball
@@ -92,7 +92,7 @@ src_compile() {
if use opengl; then
myconf="--enable-opengl"
# the nvidia drivers *seem* not to work together with pthreads
- if ! /usr/sbin/opengl-update --get-implementation | grep -q nvidia; then
+ if ! /usr/bin/eselect opengl show | grep -q nvidia; then
myconf="$myconf --with-pthreads"
fi
fi