summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice-libs/koffice-libs-1.4.0_rc1.ebuild')
-rw-r--r--app-office/koffice-libs/koffice-libs-1.4.0_rc1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/app-office/koffice-libs/koffice-libs-1.4.0_rc1.ebuild b/app-office/koffice-libs/koffice-libs-1.4.0_rc1.ebuild
deleted file mode 100644
index 1d74a39f36f6..000000000000
--- a/app-office/koffice-libs/koffice-libs-1.4.0_rc1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-1.4.0_rc1.ebuild,v 1.1 2005/06/03 15:20:32 greg_g Exp $
-
-MAXKOFFICEVER=${PV}
-KMNAME=koffice
-KMMODULE=lib
-inherit kde-meta eutils
-
-DESCRIPTION="Shared KOffice libraries."
-HOMEPAGE="http://www.koffice.org/"
-LICENSE="GPL-2 LGPL-2"
-
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="doc"
-
-RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-data)"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- dev-util/pkgconfig"
-
-KMEXTRA="
- interfaces/
- plugins/
- tools/
- filters/olefilters/
- filters/xsltfilter/
- filters/generic_wrapper/
- kounavail/
- doc/api/
- doc/koffice/
- doc/thesaurus/"
-
-KMEXTRACTONLY="
- kchart/kdchart/"
-
-need-kde 3.3
-
-src_unpack() {
- kde-meta_src_unpack unpack
-
- # Force the compilation of libkopainter.
- sed -i 's:$(KOPAINTERDIR):kopainter:' $S/lib/Makefile.am
-
- kde-meta_src_unpack makefiles
-}
-
-src_compile() {
- kde-meta_src_compile
- if use doc; then
- make apidox || die
- fi
-}
-
-src_install() {
- kde-meta_src_install
- if use doc; then
- make DESTDIR=${D} install-apidox || die
- fi
-}