summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog7
-rw-r--r--app-office/karbon/karbon-2.1.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index 2d8621914e6c..5cbca55c0e2f 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.106 2010/01/24 13:40:00 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.107 2010/02/27 21:52:10 ssuominen Exp $
+
+*karbon-2.1.1 (27 Feb 2010)
+
+ 27 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> +karbon-2.1.1.ebuild:
+ Version bump.
24 Jan 2010; Brent Baude <ranger@gentoo.org> karbon-2.1.0.ebuild:
Marking karbon-2.1.0 ~ppc for bug 295884
diff --git a/app-office/karbon/karbon-2.1.1.ebuild b/app-office/karbon/karbon-2.1.1.ebuild
new file mode 100644
index 000000000000..55d8da9664b7
--- /dev/null
+++ b/app-office/karbon/karbon-2.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-2.1.1.ebuild,v 1.1 2010/02/27 21:52:10 ssuominen Exp $
+
+EAPI="2"
+KMNAME="koffice"
+KMMODULE="${PN}"
+
+inherit kde4-meta
+
+DESCRIPTION="KOffice vector drawing application."
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="+pstoedit wpg"
+
+DEPEND="
+ media-libs/libart_lgpl
+ pstoedit? ( media-gfx/pstoedit )
+ wpg? ( media-libs/libwpg )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}"
+KMEXTRACTONLY="
+ libs/
+ plugins/
+ filters/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpg)
+ $(cmake-utils_use_with pstoedit)"
+ kde4-meta_src_configure
+}