summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/company-mode/company-mode-0.3.1.ebuild')
-rw-r--r--app-emacs/company-mode/company-mode-0.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/company-mode/company-mode-0.3.1.ebuild b/app-emacs/company-mode/company-mode-0.3.1.ebuild
new file mode 100644
index 000000000000..b5dcfc12baa8
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/company-mode-0.3.1.ebuild,v 1.1 2009/04/16 08:42:38 ulm Exp $
+
+EAPI=2
+NEED_EMACS=22
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://nschum.de/src/emacs/company-mode/"
+SRC_URI="http://nschum.de/src/emacs/${PN}/company-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="semantic? ( app-emacs/cedet )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ # Disable semantic backend, unless selected by its USE flag
+ if ! use semantic; then
+ elog "Disabling semantic backend, as requested by USE=-semantic"
+ rm "company-semantic.el" || die
+ sed -i -e "s/company-semantic *//" company.el || die
+ fi
+}