summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/ChangeLog6
-rw-r--r--app-admin/paxtest/paxtest-0.9.5-r1.ebuild12
-rw-r--r--app-admin/paxtest/paxtest-0.9.6.ebuild6
-rw-r--r--app-admin/paxtest/paxtest-0.9.7_pre4.ebuild12
4 files changed, 20 insertions, 16 deletions
diff --git a/app-admin/paxtest/ChangeLog b/app-admin/paxtest/ChangeLog
index 9e545ff3f435..23b69eb5628b 100644
--- a/app-admin/paxtest/ChangeLog
+++ b/app-admin/paxtest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/paxtest
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.32 2009/09/23 15:01:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.33 2009/10/11 23:39:34 halcy0n Exp $
+
+ 11 Oct 2009; Mark Loeser <halcy0n@gentoo.org> paxtest-0.9.5-r1.ebuild,
+ paxtest-0.9.6.ebuild, paxtest-0.9.7_pre4.ebuild:
+ QA fixes; unquoted variables
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> paxtest-0.9.5-r1.ebuild,
paxtest-0.9.6.ebuild:
diff --git a/app-admin/paxtest/paxtest-0.9.5-r1.ebuild b/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
index ab08ddbc1ba1..ecbea4ea32b8 100644
--- a/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.5-r1.ebuild,v 1.14 2009/09/23 15:01:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.5-r1.ebuild,v 1.15 2009/10/11 23:39:34 halcy0n Exp $
inherit eutils
@@ -20,23 +20,23 @@ DEPEND=">=sys-apps/chpax-0.5"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/paxtest-0.9.5.1.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/paxtest-0.9.5.1.diff
# paxtest includes crt1S.S, which is great if you're on x86, but not so
# much if you're not...
- use !x86 && epatch ${FILESDIR}/paxtest-0.9.5-use-fPIE.patch
+ use !x86 && epatch "${FILESDIR}"/paxtest-0.9.5-use-fPIE.patch
cp Makefile{,.orig}
cp Makefile{.Gentoo-hardened,}
}
src_compile() {
- emake DESTDIR=${D} BINDIR=${D}/usr/bin RUNDIR=/usr/lib/paxtest || die
+ emake DESTDIR="${D}" BINDIR="${D}"/usr/bin RUNDIR=/usr/lib/paxtest || die
}
src_install() {
- emake DESTDIR=${D} BINDIR=/usr/bin RUNDIR=/usr/lib/paxtest install
+ emake DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/lib/paxtest install
for doc in Changelog README ;do
[ -f "${doc}" ] && dodoc ${doc}
done
diff --git a/app-admin/paxtest/paxtest-0.9.6.ebuild b/app-admin/paxtest/paxtest-0.9.6.ebuild
index 8e15e147755d..0b2e84ce86a1 100644
--- a/app-admin/paxtest/paxtest-0.9.6.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.6.ebuild,v 1.17 2009/09/23 15:01:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.6.ebuild,v 1.18 2009/10/11 23:39:34 halcy0n Exp $
inherit eutils multilib
@@ -19,11 +19,11 @@ DEPEND=">=sys-apps/chpax-0.5"
src_unpack() {
unpack ${A}
- cp ${FILESDIR}/Makefile-portable ${S}/Makefile
+ cp "${FILESDIR}"/Makefile-portable "${S}"/Makefile
}
src_compile() {
- emake DESTDIR=${D} BINDIR=${D}/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest || die
+ emake DESTDIR="${D}" BINDIR="${D}"/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest || die
}
src_install() {
diff --git a/app-admin/paxtest/paxtest-0.9.7_pre4.ebuild b/app-admin/paxtest/paxtest-0.9.7_pre4.ebuild
index 811916b6fb4d..43712b1f2589 100644
--- a/app-admin/paxtest/paxtest-0.9.7_pre4.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.7_pre4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.7_pre4.ebuild,v 1.3 2007/11/13 18:22:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.7_pre4.ebuild,v 1.4 2009/10/11 23:39:34 halcy0n Exp $
inherit eutils multilib
@@ -25,13 +25,13 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- cp ${FILESDIR}/Makefile.psm5 ${S}/Makefile || die
- sed -i 's:-O2:${CFLAGS}:' ${S}/Makefile
+ cd "${S}"
+ cp "${FILESDIR}"/Makefile.psm5 "${S}"/Makefile || die
+ sed -i 's:-O2:${CFLAGS}:' "${S}"/Makefile
}
src_compile() {
- emake DESTDIR=${D} BINDIR=${D}/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest || die
+ emake DESTDIR="${D}" BINDIR="${D}"/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest || die
}
src_install() {