summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/vimpc/ChangeLog11
-rw-r--r--media-sound/vimpc/metadata.xml10
-rw-r--r--media-sound/vimpc/vimpc-0.02.2.ebuild34
-rw-r--r--media-sound/vimpc/vimpc-9999.ebuild36
4 files changed, 91 insertions, 0 deletions
diff --git a/media-sound/vimpc/ChangeLog b/media-sound/vimpc/ChangeLog
new file mode 100644
index 000000000000..c8c4bf6a60b4
--- /dev/null
+++ b/media-sound/vimpc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/vimpc
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vimpc/ChangeLog,v 1.1 2011/06/27 10:14:32 angelos Exp $
+
+*vimpc-9999 (27 Jun 2011)
+*vimpc-0.02.2 (27 Jun 2011)
+
+ 27 Jun 2011; Christoph Mende <angelos@gentoo.org> +vimpc-0.02.2.ebuild,
+ +vimpc-9999.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/media-sound/vimpc/metadata.xml b/media-sound/vimpc/metadata.xml
new file mode 100644
index 000000000000..615a5d81edfa
--- /dev/null
+++ b/media-sound/vimpc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/media-sound/vimpc/vimpc-0.02.2.ebuild b/media-sound/vimpc/vimpc-0.02.2.ebuild
new file mode 100644
index 000000000000..67dbb866c4ef
--- /dev/null
+++ b/media-sound/vimpc/vimpc-0.02.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vimpc/vimpc-0.02.2.ebuild,v 1.1 2011/06/27 10:14:32 angelos Exp $
+
+EAPI=4
+
+DESCRIPTION="An ncurses based mpd client with vi like key bindings."
+HOMEPAGE="http://vimpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/Release%200.02/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libpcre[cxx]
+ media-libs/libmpdclient"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ # vimpc will look for help.txt
+ docompress -x /usr/share/doc/${PF}/help.txt
+}
diff --git a/media-sound/vimpc/vimpc-9999.ebuild b/media-sound/vimpc/vimpc-9999.ebuild
new file mode 100644
index 000000000000..e7938f892730
--- /dev/null
+++ b/media-sound/vimpc/vimpc-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vimpc/vimpc-9999.ebuild,v 1.1 2011/06/27 10:14:32 angelos Exp $
+
+EAPI=4
+inherit autotools subversion
+
+DESCRIPTION="An ncurses based mpd client with vi like key bindings."
+HOMEPAGE="http://vimpc.sourceforge.net/"
+ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${PN}/trunk"
+ESVN_BOOTSTRAP="eautoreconf"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/libpcre[cxx]
+ media-libs/libmpdclient"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ # vimpc will look for help.txt
+ docompress -x /usr/share/doc/${PF}/help.txt
+}