summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/commoncpp2/ChangeLog5
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 5201b6e83f93..70ebcc2ea541 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.23 2006/10/22 15:59:12 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.24 2006/10/22 16:39:39 dev-zero Exp $
+
+ 22 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
+ 'examples' USE-flag added: bug #139999
22 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
'debug' and 'gnutls' USE-flags added. Dependencies corrected.
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
index 38116e2b89b0..37280b5dbcad 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild,v 1.1 2006/10/22 15:59:12 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild,v 1.2 2006/10/22 16:39:39 dev-zero Exp $
inherit autotools eutils
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.gnu.org/software/commoncpp/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug doc ipv6 gnutls"
+IUSE="debug doc examples ipv6 gnutls"
RDEPEND="gnutls? ( dev-libs/libgcrypt
net-libs/gnutls )
@@ -53,4 +53,10 @@ src_install () {
# Only install html docs
# man and latex available, but seems a little wasteful
use doc && dohtml doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ cd demo
+ doins *.cpp *.h *.xml README
+ fi
}