summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python-exec/ChangeLog7
-rw-r--r--dev-lang/python-exec/python-exec-0.3.1.ebuild3
-rw-r--r--dev-lang/python-exec/python-exec-0.9999.ebuild3
-rw-r--r--dev-lang/python-exec/python-exec-2.0.ebuild3
-rw-r--r--dev-lang/python-exec/python-exec-2.9999.ebuild3
5 files changed, 14 insertions, 5 deletions
diff --git a/dev-lang/python-exec/ChangeLog b/dev-lang/python-exec/ChangeLog
index 58def6adf1e7..50582b7dac01 100644
--- a/dev-lang/python-exec/ChangeLog
+++ b/dev-lang/python-exec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python-exec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.2 2013/11/09 17:22:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.3 2013/11/15 22:12:48 robbat2 Exp $
+
+ 15 Nov 2013; Robin H. Johnson <robbat2@gentoo.org> python-exec-0.3.1.ebuild,
+ python-exec-0.9999.ebuild, python-exec-2.0.ebuild, python-exec-2.9999.ebuild:
+ Use PDEPEND to fix python-exec dep for all users, acked by ZeroChaos & mgorny
+ in #gentoo-dev.
09 Nov 2013; Pacho Ramos <pacho@gentoo.org> python-exec-2.0.ebuild:
amd64 stable, bug #488682
diff --git a/dev-lang/python-exec/python-exec-0.3.1.ebuild b/dev-lang/python-exec/python-exec-0.3.1.ebuild
index 54029bd5bed4..d5743fdb9ca4 100644
--- a/dev-lang/python-exec/python-exec-0.3.1.ebuild
+++ b/dev-lang/python-exec/python-exec-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.3.1.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.3.1.ebuild,v 1.2 2013/11/15 22:12:48 robbat2 Exp $
EAPI=5
@@ -20,6 +20,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
+PDEPEND=">=dev-python/python-exec-10000:$SLOT"
src_configure() {
local pyimpls i EPYTHON
diff --git a/dev-lang/python-exec/python-exec-0.9999.ebuild b/dev-lang/python-exec/python-exec-0.9999.ebuild
index bddfa857304f..335614c032e3 100644
--- a/dev-lang/python-exec/python-exec-0.9999.ebuild
+++ b/dev-lang/python-exec/python-exec-0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.9999.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.9999.ebuild,v 1.2 2013/11/15 22:12:48 robbat2 Exp $
EAPI=5
@@ -27,6 +27,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
+PDEPEND=">=dev-python/python-exec-10000:$SLOT"
#if LIVE
KEYWORDS=
diff --git a/dev-lang/python-exec/python-exec-2.0.ebuild b/dev-lang/python-exec/python-exec-2.0.ebuild
index c87cf5bfb1b6..5242ccd6433e 100644
--- a/dev-lang/python-exec/python-exec-2.0.ebuild
+++ b/dev-lang/python-exec/python-exec-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.0.ebuild,v 1.2 2013/11/09 17:22:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.0.ebuild,v 1.3 2013/11/15 22:12:48 robbat2 Exp $
EAPI=5
@@ -20,6 +20,7 @@ KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
+PDEPEND=">=dev-python/python-exec-10000:$SLOT"
src_configure() {
local pyimpls i EPYTHON
diff --git a/dev-lang/python-exec/python-exec-2.9999.ebuild b/dev-lang/python-exec/python-exec-2.9999.ebuild
index a5b8553a4541..30a314621040 100644
--- a/dev-lang/python-exec/python-exec-2.9999.ebuild
+++ b/dev-lang/python-exec/python-exec-2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.9999.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.9999.ebuild,v 1.2 2013/11/15 22:12:48 robbat2 Exp $
EAPI=5
@@ -28,6 +28,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
+PDEPEND=">=dev-python/python-exec-10000:$SLOT"
#if LIVE
KEYWORDS=