summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/asc/ChangeLog7
-rw-r--r--games-strategy/asc/asc-2.2.0.0.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/games-strategy/asc/ChangeLog b/games-strategy/asc/ChangeLog
index 1e5c4988a9b2..f7d01fe5f5d5 100644
--- a/games-strategy/asc/ChangeLog
+++ b/games-strategy/asc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/asc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.27 2008/11/17 17:19:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.28 2008/12/17 16:27:03 mr_bones_ Exp $
+
+*asc-2.2.0.0 (17 Dec 2008)
+
+ 17 Dec 2008; Michael Sterrett <mr_bones_@gentoo.org> +asc-2.2.0.0.ebuild:
+ version bump
17 Nov 2008; Michael Sterrett <mr_bones_@gentoo.org> asc-2.1.0.0.ebuild:
add libpng dep (bug #247090)
diff --git a/games-strategy/asc/asc-2.2.0.0.ebuild b/games-strategy/asc/asc-2.2.0.0.ebuild
new file mode 100644
index 000000000000..6626baae492e
--- /dev/null
+++ b/games-strategy/asc/asc-2.2.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.2.0.0.ebuild,v 1.1 2008/12/17 16:27:03 mr_bones_ Exp $
+
+inherit toolchain-funcs flag-o-matic games
+
+DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
+HOMEPAGE="http://www.asc-hq.org/"
+SRC_URI="mirror://sourceforge/asc-hq/${P}.tar.bz2
+ http://www.asc-hq.org/music/frontiers.ogg
+ http://www.asc-hq.org/music/time_to_strike.ogg
+ http://www.asc-hq.org/music/machine_wars.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ media-libs/jpeg
+ media-libs/libsdl
+ media-libs/libpng
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ dev-libs/boost
+ dev-games/physfs
+ media-libs/smpeg
+ media-libs/libvorbis
+ dev-libs/expat
+ media-libs/freetype
+ =dev-libs/libsigc++-1.2*"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig"
+
+src_unpack() {
+ local f
+
+ unpack ${P}.tar.bz2
+ for f in ${A}
+ do
+ case ${f} in
+ *ogg)
+ cp "${DISTDIR}/${f}" "${S}/data/music" || die "cp music failed"
+ ;;
+ esac
+ done
+}
+
+src_compile() {
+ # Added --disable-paraguitest for bugs 26402 and 4488
+ # Added --disable-paragui for bug 61154 since it's not really used much
+ # and the case is well documented at http://www.asc-hq.org/
+ if [[ $(gcc-major-version) -eq 4 ]] ; then
+ replace-flags -O3 -O2
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-paraguitest \
+ --disable-paragui \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r doc/*
+ prepgamesdirs
+}