summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-rpg/tmw/ChangeLog8
-rw-r--r--games-rpg/tmw/files/digest-tmw-0.0.236
-rw-r--r--games-rpg/tmw/files/tmw-0.0.23-desktop.patch22
-rw-r--r--games-rpg/tmw/tmw-0.0.23.ebuild60
4 files changed, 95 insertions, 1 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index 3c0f1d9fea79..16ea4a0be511 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.24 2007/03/13 19:14:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.25 2007/06/06 18:42:37 mr_bones_ Exp $
+
+*tmw-0.0.23 (06 Jun 2007)
+
+ 06 Jun 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/tmw-0.0.23-desktop.patch, +tmw-0.0.23.ebuild:
+ version bump
*tmw-0.0.22.2 (13 Mar 2007)
diff --git a/games-rpg/tmw/files/digest-tmw-0.0.23 b/games-rpg/tmw/files/digest-tmw-0.0.23
new file mode 100644
index 000000000000..650a6d951116
--- /dev/null
+++ b/games-rpg/tmw/files/digest-tmw-0.0.23
@@ -0,0 +1,6 @@
+MD5 4c4233a3b904dcf2935685e5ec1e6e5a tmw-0.0.23.tar.gz 3192067
+RMD160 b43c541aa98edb52eadfa78891e31591478f3cf6 tmw-0.0.23.tar.gz 3192067
+SHA256 599621951eea2c8e186fc898f3ba90010ef7c4cb6a5dae3127a8ad4fd41dbf81 tmw-0.0.23.tar.gz 3192067
+MD5 eec5e7d6c8ddb8938209815dbf5da812 tmwmusic-0.0.20.tar.gz 9259802
+RMD160 a7212f90b40f864d0670905fe037564eba48ab30 tmwmusic-0.0.20.tar.gz 9259802
+SHA256 964bb27235cdc3199c392f6ddf25ce293c6f32e013abe85592b96221a5896939 tmwmusic-0.0.20.tar.gz 9259802
diff --git a/games-rpg/tmw/files/tmw-0.0.23-desktop.patch b/games-rpg/tmw/files/tmw-0.0.23-desktop.patch
new file mode 100644
index 000000000000..127efd371f3a
--- /dev/null
+++ b/games-rpg/tmw/files/tmw-0.0.23-desktop.patch
@@ -0,0 +1,22 @@
+Make sure desktop/pixmaps dont get thrown into /usr/games.
+
+--- Makefile.in
++++ Makefile.in
+@@ -163,3 +163,3 @@
+ SUBDIRS = data docs src
+-desktopdir = $(datadir)/applications
++desktopdir =/usr/share/applications
+ desktop_DATA = tmw.desktop
+--- data/icons/Makefile.in
++++ data/icons/Makefile.in
+@@ -318,7 +318,7 @@
+ install-data-local:
+- $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps
+- $(INSTALL) $(srcdir)/tmw.png $(DESTDIR)$(datadir)/pixmaps/tmw.png
++ $(mkinstalldirs) $(DESTDIR)/usr/share/pixmaps
++ $(INSTALL) $(srcdir)/tmw.png $(DESTDIR)/usr/share/pixmaps/tmw.png
+
+ uninstall-local:
+- rm -f $(DESTDIR)$(datadir)/pixmaps/tmw.png
++ rm -f $(DESTDIR)/usr/share/pixmaps/tmw.png
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/games-rpg/tmw/tmw-0.0.23.ebuild b/games-rpg/tmw/tmw-0.0.23.ebuild
new file mode 100644
index 000000000000..58e239da38e6
--- /dev/null
+++ b/games-rpg/tmw/tmw-0.0.23.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.23.ebuild,v 1.1 2007/06/06 18:42:37 mr_bones_ Exp $
+
+inherit eutils games
+
+MUSIC=tmwmusic-0.0.20
+DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
+HOMEPAGE="http://themanaworld.org/"
+SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz
+ mirror://sourceforge/themanaworld/${MUSIC}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND=">=dev-games/physfs-1.0.0
+ opengl? ( virtual/opengl )
+ dev-libs/libxml2
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net
+ net-misc/curl
+ >=dev-games/guichan-0.6.0"
+
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use dev-games/guichan sdl ; then
+ eerror "dev-games/guichan needs to be built with USE=sdl"
+ die "please re-emerge dev-games/guichan with USE=sdl"
+ fi
+ if ! built_with_use media-libs/sdl-mixer vorbis ; then
+ eerror "media-libs/sdl-mixer needs to be built with USE=vorbis"
+ die "please re-emerge media-libs/sdl-mixer with USE=vorbis"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-desktop.patch
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_with opengl) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ cd ${WORKDIR}
+ insinto "${GAMES_DATADIR}"/${PN}/data/music
+ doins ${MUSIC}/data/music/*.ogg || die
+ newdoc ${MUSIC}/README README.music
+ prepgamesdirs
+}