summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/groff/ChangeLog7
-rw-r--r--sys-apps/groff/groff-1.20.1-r1.ebuild15
2 files changed, 19 insertions, 3 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 08eebfb74dc7..d6cdc677901c 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/groff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.101 2009/03/14 14:37:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.102 2009/08/16 04:38:31 mr_bones_ Exp $
+
+ 16 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ groff-1.20.1-r1.ebuild:
+ Fix docs install and add examples use flag to control the install of
+ the large number of example files (bug #281158)
14 Mar 2009; Mike Frysinger <vapier@gentoo.org> groff-1.20.1-r1.ebuild:
Add distro overlays to groff man page output #262163 by Roy Marples.
diff --git a/sys-apps/groff/groff-1.20.1-r1.ebuild b/sys-apps/groff/groff-1.20.1-r1.ebuild
index 169ee2bd9637..81b3963009a9 100644
--- a/sys-apps/groff/groff-1.20.1-r1.ebuild
+++ b/sys-apps/groff/groff-1.20.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r1.ebuild,v 1.10 2009/03/14 14:37:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r1.ebuild,v 1.11 2009/08/16 04:38:31 mr_bones_ Exp $
inherit eutils toolchain-funcs autotools
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/groff/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="X linguas_ja"
+IUSE="examples X linguas_ja"
DEPEND=">=sys-apps/texinfo-4.7-r1
X? (
@@ -30,6 +30,12 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+ # put the docs in the Gentoo-specific spot
+ sed -i \
+ -e '/^docdir=/s/=.*/=@docdir@/' \
+ Makefile.in \
+ || die "sed failed"
+
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then
sed -i \
@@ -59,6 +65,7 @@ src_compile() {
# tc-export CC CXX
econf \
--with-appresdir=/usr/share/X11/app-defaults \
+ --docdir=/usr/share/doc/${PF} \
$(use_with X x) \
$(use linguas_ja && echo --enable-japanese)
emake || die
@@ -73,4 +80,8 @@ src_install() {
dodoc BUG-REPORT ChangeLog MORE.STUFF NEWS \
PROBLEMS PROJECTS README REVISION TODO VERSION
+
+ if ! use examples ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/examples
+ fi
}