summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cvsweb/cvsweb-1.112.ebuild7
-rw-r--r--dev-util/cvsweb/cvsweb-1.93-r1.ebuild6
-rw-r--r--dev-util/cvsweb/cvsweb-3.0.1.ebuild14
-rw-r--r--dev-util/cvsweb/cvsweb-3.0.5.ebuild14
-rw-r--r--dev-util/cvsweb/cvsweb-3.0.6.ebuild14
5 files changed, 27 insertions, 28 deletions
diff --git a/dev-util/cvsweb/cvsweb-1.112.ebuild b/dev-util/cvsweb/cvsweb-1.112.ebuild
index b1893663c087..5fa3462b86c0 100644
--- a/dev-util/cvsweb/cvsweb-1.112.ebuild
+++ b/dev-util/cvsweb/cvsweb-1.112.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-1.112.ebuild,v 1.2 2005/04/16 00:40:23 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-1.112.ebuild,v 1.3 2009/10/12 17:00:59 ssuominen Exp $
DESCRIPTION="WWW interface to a CVS tree"
HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
@@ -18,7 +18,7 @@ S="${WORKDIR}/cvsweb"
src_unpack() {
unpack ${P}.tar.gz
- cd ${S}
+ cd "${S}"
local x
for x in cvsweb.cgi cvsweb.conf
do
@@ -28,7 +28,6 @@ src_unpack() {
}
src_install() {
- cd ${S}
insinto /etc/apache/conf
doins cvsweb.conf
insinto /home/httpd/cgi-bin
diff --git a/dev-util/cvsweb/cvsweb-1.93-r1.ebuild b/dev-util/cvsweb/cvsweb-1.93-r1.ebuild
index b0f88cb1ffcf..a7456be8d8ca 100644
--- a/dev-util/cvsweb/cvsweb-1.93-r1.ebuild
+++ b/dev-util/cvsweb/cvsweb-1.93-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-1.93-r1.ebuild,v 1.2 2005/04/16 00:40:23 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-1.93-r1.ebuild,v 1.3 2009/10/12 17:00:59 ssuominen Exp $
DESCRIPTION="WWW interface to a CVS tree"
HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
@@ -18,7 +18,7 @@ S="${WORKDIR}/cvsweb"
src_unpack () {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i "s:/usr/local/web/apache/conf/:/etc/httpd/:" cvsweb.cgi cvsweb.conf
}
diff --git a/dev-util/cvsweb/cvsweb-3.0.1.ebuild b/dev-util/cvsweb/cvsweb-3.0.1.ebuild
index f920bdebb9ab..5b09e9c4652f 100644
--- a/dev-util/cvsweb/cvsweb-3.0.1.ebuild
+++ b/dev-util/cvsweb/cvsweb-3.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.1.ebuild,v 1.4 2005/08/21 15:13:44 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.1.ebuild,v 1.5 2009/10/12 17:00:59 ssuominen Exp $
inherit webapp
@@ -26,15 +26,15 @@ RDEPEND=">=dev-lang/perl-5.8
src_install() {
webapp_src_preinst
- cp cvsweb.conf ${D}/${MY_HOSTROOTDIR}
- cp css/cvsweb.css ${D}/${MY_HTDOCSDIR}
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
exeinto ${MY_CGIBINDIR}
doexe cvsweb.cgi
- chmod +x ${D}/${MY_CGIBINDIR}/cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
dodoc README TODO NEWS ChangeLog
- webapp_hook_script ${FILESDIR}/reconfig
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}
diff --git a/dev-util/cvsweb/cvsweb-3.0.5.ebuild b/dev-util/cvsweb/cvsweb-3.0.5.ebuild
index 2f167dc16e59..ce4f1e4f5baf 100644
--- a/dev-util/cvsweb/cvsweb-3.0.5.ebuild
+++ b/dev-util/cvsweb/cvsweb-3.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.5.ebuild,v 1.2 2005/07/16 15:35:45 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.5.ebuild,v 1.3 2009/10/12 17:00:59 ssuominen Exp $
inherit webapp
@@ -26,15 +26,15 @@ RDEPEND=">=dev-lang/perl-5.8
src_install() {
webapp_src_preinst
- cp cvsweb.conf ${D}/${MY_HOSTROOTDIR}
- cp css/cvsweb.css ${D}/${MY_HTDOCSDIR}
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
exeinto ${MY_CGIBINDIR}
doexe cvsweb.cgi
- chmod +x ${D}/${MY_CGIBINDIR}/cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
dodoc README TODO NEWS ChangeLog
- webapp_hook_script ${FILESDIR}/reconfig
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}
diff --git a/dev-util/cvsweb/cvsweb-3.0.6.ebuild b/dev-util/cvsweb/cvsweb-3.0.6.ebuild
index 74f725dab7a6..43815c9890ac 100644
--- a/dev-util/cvsweb/cvsweb-3.0.6.ebuild
+++ b/dev-util/cvsweb/cvsweb-3.0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.6.ebuild,v 1.4 2007/02/19 20:14:37 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.6.ebuild,v 1.5 2009/10/12 17:00:59 ssuominen Exp $
inherit webapp
@@ -26,15 +26,15 @@ RDEPEND=">=dev-lang/perl-5.8
src_install() {
webapp_src_preinst
- cp cvsweb.conf ${D}/${MY_HOSTROOTDIR}
- cp css/cvsweb.css ${D}/${MY_HTDOCSDIR}
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
exeinto ${MY_CGIBINDIR}
doexe cvsweb.cgi
- chmod +x ${D}/${MY_CGIBINDIR}/cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
dodoc README TODO NEWS ChangeLog
- webapp_hook_script ${FILESDIR}/reconfig
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}