summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/x11vnc/ChangeLog7
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.8-xshm-header-fix.patch22
2 files changed, 18 insertions, 11 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index 21ccdbf57ac5..3c9c62b24ad8 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.72 2009/11/06 22:06:57 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.73 2009/11/14 09:41:38 swegener Exp $
+
+ 14 Nov 2009; Sven Wegener <swegener@gentoo.org>
+ files/x11vnc-0.9.8-xshm-header-fix.patch:
+ Fix xshm once more, just hardcode the value that we need from the headers,
+ bug #292229.
06 Nov 2009; Sven Wegener <swegener@gentoo.org> x11vnc-0.9.6.ebuild,
x11vnc-0.9.7.ebuild, x11vnc-0.9.8.ebuild:
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.8-xshm-header-fix.patch b/x11-misc/x11vnc/files/x11vnc-0.9.8-xshm-header-fix.patch
index b25f2ed2baca..6796d55beb05 100644
--- a/x11-misc/x11vnc/files/x11vnc-0.9.8-xshm-header-fix.patch
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.8-xshm-header-fix.patch
@@ -1,13 +1,15 @@
---- x11vnc-0.9.8/x11vnc/x11vnc.h
-+++ x11vnc-0.9.8/x11vnc/x11vnc.h
-@@ -76,6 +76,10 @@
- #include <X11/keysym.h>
- #include <X11/Xatom.h>
+Looks like X_ShmAttach is considered private to the library and has been removed from its headers.
+Just hardcode the value, it's only usd to print some help in case of an shm attach error.
+--- x11vnc-0.9.8/x11vnc/cleanup.c
++++ x11vnc-0.9.8/x11vnc/cleanup.c
+@@ -276,6 +276,10 @@
+ return 0;
+ }
-+#include <X11/Xmd.h>
-+#include <X11/extensions/shm.h>
-+#include <X11/extensions/shmproto.h>
++#ifndef X_ShmAttach
++#define X_ShmAttach 1
++#endif
+
- #else
+ static int Xerror(Display *d, XErrorEvent *error) {
+ X_UNLOCK;
- #define NO_X11 1