summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/project-template/ChangeLog9
-rw-r--r--dev-haskell/project-template/project-template-0.1.4.1.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-haskell/project-template/ChangeLog b/dev-haskell/project-template/ChangeLog
index c8533e698031..ebc83d9f3cda 100644
--- a/dev-haskell/project-template/ChangeLog
+++ b/dev-haskell/project-template/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/project-template
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/project-template/ChangeLog,v 1.1 2013/08/26 12:38:06 qnikst Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/project-template/ChangeLog,v 1.2 2014/07/02 15:49:57 gienah Exp $
+
+*project-template-0.1.4.1 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +project-template-0.1.4.1.ebuild:
+ Bump project-template to 0.1.4.1
*project-template-0.1.3 (26 Aug 2013)
diff --git a/dev-haskell/project-template/project-template-0.1.4.1.ebuild b/dev-haskell/project-template/project-template-0.1.4.1.ebuild
new file mode 100644
index 000000000000..7ac0988c24a3
--- /dev/null
+++ b/dev-haskell/project-template/project-template-0.1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/project-template/project-template-0.1.4.1.ebuild,v 1.1 2014/07/02 15:49:57 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Specify Haskell project templates and generate files"
+HOMEPAGE="https://github.com/fpco/haskell-ide"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.2:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?]
+ >=dev-haskell/system-fileio-0.3:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/conduit
+ >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"