summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/pinentry/ChangeLog7
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.2-r11
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2-r1.ebuild60
3 files changed, 67 insertions, 1 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 5645e399b6de..1f942a9813fb 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.29 2005/09/19 13:58:45 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.30 2005/09/22 10:23:26 swegener Exp $
+
+*pinentry-0.7.2-r1 (22 Sep 2005)
+
+ 22 Sep 2005; Sven Wegener <swegener@gentoo.org> +pinentry-0.7.2-r1.ebuild:
+ Deprecate gtk2 USE flag, bug #106560.
19 Sep 2005; Gustavo Zacarias <gustavoz@gentoo.org> pinentry-0.7.2.ebuild:
Stable on sparc
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.2-r1 b/app-crypt/pinentry/files/digest-pinentry-0.7.2-r1
new file mode 100644
index 000000000000..a609eac13900
--- /dev/null
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.2-r1
@@ -0,0 +1 @@
+MD5 55626ce13ed76d82ec5330d19bdf3ab4 pinentry-0.7.2.tar.gz 398775
diff --git a/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild b/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..c174df16b423
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild,v 1.1 2005/09/22 10:23:26 swegener Exp $
+
+inherit flag-o-matic qt3
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="gtk ncurses qt"
+
+DEPEND="gtk? ( =x11-libs/gtk+-2* )
+ ncurses? ( sys-libs/ncurses )
+ qt? ( $(qt_min_version 3.3) )
+ !gtk? ( !qt? ( !ncurses? ( sys-libs/ncurses ) ) )"
+
+src_compile() {
+ local myconf=""
+
+ if ! ( use qt || use gtk || use ncurses )
+ then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+
+ append-ldflags -Wl,-z,now
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-maintainer-mode \
+ --disable-pinentry-gtk \
+ $(use_enable gtk gtk2) \
+ $(use_enable qt pinentry-qt) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+
+ # gtk versions of pinentry refuse to start when suid root
+ for x in curses qt
+ do
+ [ -f "${D}"/usr/bin/pinentry-${x} ] && fperms +s /usr/bin/pinentry-${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "pinentry-curses and pinentry-qt are installed SUID root to make use of"
+ einfo "protected memory space. This is needed in order to have a secure place"
+ einfo "to store your passphrases, etc. at runtime but may make some sysadmins"
+ einfo "nervous."
+}