summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-04 19:58:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-04 19:58:36 +0000
commit6057e2b883b583ebd65bf3da351f00d35085e8b6 (patch)
treeb4bd2095778f5b22439039710c8497efddd142e0 /xfce-base/tumbler/tumbler-0.1.0.ebuild
parentVersion bump, bug #273351, thank Bruno 'brubru' Tarquini for this work. Fixes... (diff)
downloadgentoo-2-6057e2b883b583ebd65bf3da351f00d35085e8b6.tar.gz
gentoo-2-6057e2b883b583ebd65bf3da351f00d35085e8b6.tar.bz2
gentoo-2-6057e2b883b583ebd65bf3da351f00d35085e8b6.zip
Initial commit, thanks to Andrew for his work
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/tumbler/tumbler-0.1.0.ebuild')
-rw-r--r--xfce-base/tumbler/tumbler-0.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-base/tumbler/tumbler-0.1.0.ebuild b/xfce-base/tumbler/tumbler-0.1.0.ebuild
new file mode 100644
index 000000000000..88e7132fd191
--- /dev/null
+++ b/xfce-base/tumbler/tumbler-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/tumbler/tumbler-0.1.0.ebuild,v 1.1 2010/01/04 19:58:36 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="A D-Bus service for applications to request thumbnails"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.72
+ >=sys-apps/dbus-1
+ >=media-libs/libpng-1.2
+ >=x11-libs/gtk+-2.14:2
+ media-libs/freetype:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ $(use_enable debug)
+ --with-html-dir=/usr/share/doc/${PF}/html"
+}