summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-11 09:14:56 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-11 09:14:56 +0000
commit6b5c0aed3223d1d2e17cc43e458ebe7e53eb18bb (patch)
tree6a60991146c3ae851da774d8d41842fee684518b /x11-wm
parentAdded ~arm keyword (bug #344821) (diff)
downloadgentoo-2-6b5c0aed3223d1d2e17cc43e458ebe7e53eb18bb.tar.gz
gentoo-2-6b5c0aed3223d1d2e17cc43e458ebe7e53eb18bb.tar.bz2
gentoo-2-6b5c0aed3223d1d2e17cc43e458ebe7e53eb18bb.zip
Add fontcorruption.patch
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/ChangeLog9
-rw-r--r--x11-wm/compiz/compiz-0.8.6-r2.ebuild162
-rw-r--r--x11-wm/compiz/files/compiz-0.8.6-r2-fontcorruption.patch23
3 files changed, 193 insertions, 1 deletions
diff --git a/x11-wm/compiz/ChangeLog b/x11-wm/compiz/ChangeLog
index cc9f758a77c4..288b5b91df88 100644
--- a/x11-wm/compiz/ChangeLog
+++ b/x11-wm/compiz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/compiz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.57 2010/11/02 02:54:24 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.58 2010/11/11 09:14:56 xmw Exp $
+
+*compiz-0.8.6-r2 (11 Nov 2010)
+
+ 11 Nov 2010; Michael Weber <xmw@gentoo.org> +compiz-0.8.6-r2.ebuild,
+ +files/compiz-0.8.6-r2-fontcorruption.patch:
+ Add fontcorruption.patch, thanks to Manuel Danisch
+ <oeffentlicheszeug@googlemail.com> for his report (bug #343861).
02 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
compiz-0.8.6-r1.ebuild:
diff --git a/x11-wm/compiz/compiz-0.8.6-r2.ebuild b/x11-wm/compiz/compiz-0.8.6-r2.ebuild
new file mode 100644
index 000000000000..152656e01e85
--- /dev/null
+++ b/x11-wm/compiz/compiz-0.8.6-r2.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.8.6-r2.ebuild,v 1.1 2010/11/11 09:14:56 xmw Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="OpenGL window and compositing manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+cairo dbus fuse gnome gconf gtk kde +svg"
+
+COMMONDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ media-libs/libpng
+ >=media-libs/mesa-6.5.1-r1
+ >=x11-base/xorg-server-1.1.1-r1
+ || ( <x11-libs/libX11-1.3.99.901[xcb] >=x11-libs/libX11-1.3.99.901 )
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libXrender-0.8.4
+ >=x11-libs/startup-notification-0.7
+ cairo? (
+ x11-libs/cairo[X]
+ )
+ dbus? ( >=sys-apps/dbus-1.0 )
+ fuse? ( sys-fs/fuse )
+ gnome? (
+ >=gnome-base/gnome-control-center-2.16.1:2
+ gnome-base/gnome-desktop:2
+ gconf? ( gnome-base/gconf:2 )
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.8.0:2
+ >=x11-libs/libwnck-2.18.3
+ x11-libs/pango
+ )
+ kde? (
+ || (
+ >=kde-base/kwin-4.2.0
+ kde-base/kwin:live
+ )
+ )
+ svg? (
+ >=gnome-base/librsvg-2.14.0:2
+ >=x11-libs/cairo-1.0
+ )
+"
+
+DEPEND="${COMMONDEPEND}
+ dev-util/pkgconfig
+ x11-proto/damageproto
+ x11-proto/xineramaproto
+"
+
+RDEPEND="${COMMONDEPEND}
+ x11-apps/mesa-progs
+ x11-apps/xvinfo
+"
+
+src_prepare() {
+
+ echo "gtk/gnome/compiz-wm.desktop.in" >> "${S}/po/POTFILES.skip"
+ echo "metadata/core.xml.in" >> "${S}/po/POTFILES.skip"
+
+ # fix cont corruption, bug #343861
+ epatch "${FILESDIR}"/${PF}-fontcorruption.patch
+
+ if ! use gnome || ! use gconf; then
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ # We make gconf optional by itself, but only if gnome is also
+ # enabled, otherwise we simply disable it.
+ if use gnome; then
+ myconf="${myconf} $(use_enable gconf)"
+ else
+ myconf="${myconf} --disable-gconf"
+ fi
+
+ econf --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-static \
+ --disable-gnome-keybindings \
+ --with-default-plugins \
+ $(use_enable svg librsvg) \
+ $(use_enable cairo annotate) \
+ $(use_enable dbus) \
+ $(use_enable dbus dbus-glib) \
+ $(use_enable fuse) \
+ $(use_enable gnome) \
+ $(use_enable gnome metacity) \
+ $(use_enable gtk) \
+ $(use_enable kde kde4) \
+ --disable-kde \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ find "${D}" -name '*.la' -delete || die
+
+ # Install compiz-manager
+ dobin "${FILESDIR}/compiz-manager" || die "dobin failed"
+
+ # Add the full-path to lspci
+ sed -i "s#lspci#/usr/sbin/lspci#" "${D}/usr/bin/compiz-manager" || die "sed 1 failed"
+
+ # Fix the hardcoded lib paths
+ sed -i "s#/lib/#/$(get_libdir)/#g" "${D}/usr/bin/compiz-manager" || die "sed 2 failed"
+
+ # Create gentoo's config file
+ dodir /etc/xdg/compiz || die "dodir failed"
+
+ cat <<- EOF > "${D}/etc/xdg/compiz/compiz-manager"
+ COMPIZ_BIN_PATH="/usr/bin/"
+ PLUGIN_PATH="/usr/$(get_libdir)/compiz/"
+ LIBGL_NVIDIA="/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.so.1.2"
+ LIBGL_FGLRX="/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.so.1.2"
+ KWIN="$(type -p kwin)"
+ METACITY="$(type -p metacity)"
+ SKIP_CHECKS="yes"
+ EOF
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ insinto "/usr/share/applications"
+ doins "${FILESDIR}/compiz.desktop" || die "Failed to install compiz.desktop"
+}
+
+pkg_preinst() {
+ use gnome && use gconf && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gnome && use gconf && gnome2_gconf_install
+
+ ewarn "If you update to x11-wm/metacity-2.24 after you install ${P},"
+ ewarn "gtk-window-decorator will crash until you reinstall ${PN} again."
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
diff --git a/x11-wm/compiz/files/compiz-0.8.6-r2-fontcorruption.patch b/x11-wm/compiz/files/compiz-0.8.6-r2-fontcorruption.patch
new file mode 100644
index 000000000000..1ef84a17ced7
--- /dev/null
+++ b/x11-wm/compiz/files/compiz-0.8.6-r2-fontcorruption.patch
@@ -0,0 +1,23 @@
+From 0f95c41a0aa175ddf7947ba18b01f746c95594a9 Mon Sep 17 00:00:00 2001
+From: Paul Donohue <compiz@paulsd.com>
+Date: Sun, 17 Oct 2010 16:24:14 +0000
+Subject: Fix pixmap size calculation, server drawn borders are also included in
+the pixmap.
+---
+diff --git a/src/window.c b/src/window.c
+index a925288..6674643 100644
+--- a/src/window.c
++++ b/src/window.c
+@@ -1446,8 +1446,8 @@ bindWindow (CompWindow *w)
+ }
+
+ w->pixmap = XCompositeNameWindowPixmap (dpy, w->id);
+- w->width = attr.width;
+- w->height = attr.height;
++ w->width = attr.width + attr.border_width * 2;
++ w->height = attr.height + attr.border_width * 2;
+
+ XUngrabServer (dpy);
+ }
+--
+cgit v0.8.3.1-30-gff3a