summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-15 22:47:09 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-15 22:47:09 +0000
commit9a17feb84ddbf3ee763adfe5cd59aeefb53bee6d (patch)
treef9c51184a6bf98098ac42c684a86b3730d167c4a /x11-wm/treewm
parentAdding ~amd64 keyword (diff)
downloadgentoo-2-9a17feb84ddbf3ee763adfe5cd59aeefb53bee6d.tar.gz
gentoo-2-9a17feb84ddbf3ee763adfe5cd59aeefb53bee6d.tar.bz2
gentoo-2-9a17feb84ddbf3ee763adfe5cd59aeefb53bee6d.zip
Adding gcc-4.3 patch per bug 251845. Thanks to Gene Seto <geneseto@hotmail.com> for the patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/treewm')
-rw-r--r--x11-wm/treewm/ChangeLog9
-rw-r--r--x11-wm/treewm/files/treewm-0.4.5-gcc43.patch20
-rw-r--r--x11-wm/treewm/treewm-0.4.5.ebuild9
3 files changed, 33 insertions, 5 deletions
diff --git a/x11-wm/treewm/ChangeLog b/x11-wm/treewm/ChangeLog
index 914abc9b5565..d1cc37fdde16 100644
--- a/x11-wm/treewm/ChangeLog
+++ b/x11-wm/treewm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/treewm
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/ChangeLog,v 1.18 2007/01/20 18:41:04 omp Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/ChangeLog,v 1.19 2009/02/15 22:47:05 loki_val Exp $
+
+ 15 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/treewm-0.4.5-gcc43.patch, treewm-0.4.5.ebuild:
+ Adding gcc-4.3 patch per bug 251845. Thanks to Gene Seto
+ <geneseto@hotmail.com> for the patch.
20 Jan 2007; David Shakaryan <omp@gentoo.org> treewm-0.4.5.ebuild:
Add x11-misc/imake to DEPEND. (bug #162728)
diff --git a/x11-wm/treewm/files/treewm-0.4.5-gcc43.patch b/x11-wm/treewm/files/treewm-0.4.5-gcc43.patch
new file mode 100644
index 000000000000..a8faf4319871
--- /dev/null
+++ b/x11-wm/treewm/files/treewm-0.4.5-gcc43.patch
@@ -0,0 +1,20 @@
+--- treewm-0.4.5b/src/action.cc 2009-01-17 18:17:32.000000000 -0400
++++ treewm-0.4.5/src/action.cc 2009-01-17 18:20:41.000000000 -0400
+@@ -9,6 +9,7 @@
+ #include "clienttree.h"
+ #include "clientinfo.h"
+ #include <unistd.h>
++#include <string.h>
+
+ Action::Action(Section *section) {
+ s = section;
+--- treewm-0.4.5b/src/resmanager.h 2009-01-17 18:17:32.000000000 -0400
++++ treewm-0.4.5/src/resmanager.h 2009-01-17 18:21:10.000000000 -0400
+@@ -12,6 +12,7 @@
+ #include "global.h"
+ #include "client.h"
+ #include <map>
++#include <string.h>
+
+ struct ltstr {
+ bool operator() (const char* s1, const char* s2) const {
diff --git a/x11-wm/treewm/treewm-0.4.5.ebuild b/x11-wm/treewm/treewm-0.4.5.ebuild
index d37aefd74b4a..c3ade7b95c9b 100644
--- a/x11-wm/treewm/treewm-0.4.5.ebuild
+++ b/x11-wm/treewm/treewm-0.4.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/treewm-0.4.5.ebuild,v 1.11 2007/01/20 18:41:04 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/treewm-0.4.5.ebuild,v 1.12 2009/02/15 22:47:05 loki_val Exp $
+
+inherit eutils
DESCRIPTION="WindowManager that arranges the windows in a tree (not in a list)"
SRC_URI="mirror://sourceforge/treewm/${P}.tar.bz2"
@@ -22,6 +24,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+ # bug 251845
+ epatch "${FILESDIR}/${P}-gcc43.patch"
# bug 86453
sed -i -e "s:malloc:Malloc:g" "${S}"/xprop/dsimple.c
}
@@ -31,7 +35,6 @@ src_compile() {
}
src_install() {
- cd ${S}
make PREFIX="/usr" ROOT="${D}" install || die
# hack for Gentoo's doc policy: