summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-15 05:53:18 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-15 05:53:18 +0000
commit8f1a7239d93f2152518669564f390cea7907cbab (patch)
treea86489f76d47a3ad373a6e9bf7ff90c2e4e9116c /x11-themes/oxygen-gtk
parentwhitespace (diff)
downloadgentoo-2-8f1a7239d93f2152518669564f390cea7907cbab.tar.gz
gentoo-2-8f1a7239d93f2152518669564f390cea7907cbab.tar.bz2
gentoo-2-8f1a7239d93f2152518669564f390cea7907cbab.zip
Version bump in slot2.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/oxygen-gtk')
-rw-r--r--x11-themes/oxygen-gtk/ChangeLog7
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.2.4.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-themes/oxygen-gtk/ChangeLog b/x11-themes/oxygen-gtk/ChangeLog
index 0a281b2ce737..cb6eb4816cac 100644
--- a/x11-themes/oxygen-gtk/ChangeLog
+++ b/x11-themes/oxygen-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/oxygen-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.34 2012/05/04 14:05:30 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.35 2012/05/15 05:53:18 johu Exp $
+
+*oxygen-gtk-1.2.4 (15 May 2012)
+
+ 15 May 2012; Johannes Huber <johu@gentoo.org> +oxygen-gtk-1.2.4.ebuild:
+ Version bump in slot2.
04 May 2012; Johannes Huber <johu@gentoo.org> oxygen-gtk-1.0.3.ebuild,
oxygen-gtk-1.2.3.ebuild:
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.2.4.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.2.4.ebuild
new file mode 100644
index 000000000000..d39c92278072
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.2.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.2.4.ebuild,v 1.1 2012/05/15 05:53:18 johu Exp $
+
+EAPI=4
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:2 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="2"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.24.2:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(AUTHORS README)
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk2
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-2.0"
+EOF
+ doenvd 99oxygen-gtk2
+}