summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-09-16 19:00:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-09-16 19:00:12 +0000
commit9eac033b782ded15c82b700366431fffec49d54f (patch)
tree2f667d74d47d83987df8df3e02c87e3944f05ddb /x11-misc/xplanet
parentVersion bump. (diff)
downloadgentoo-2-9eac033b782ded15c82b700366431fffec49d54f.tar.gz
gentoo-2-9eac033b782ded15c82b700366431fffec49d54f.tar.bz2
gentoo-2-9eac033b782ded15c82b700366431fffec49d54f.zip
Version bump. Also fixes bug #383215
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xplanet')
-rw-r--r--x11-misc/xplanet/ChangeLog9
-rw-r--r--x11-misc/xplanet/xplanet-1.2.2.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 34a221da0ae6..f3ee228e7b38 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xplanet
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.68 2010/11/08 12:44:04 nelchael Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.69 2011/09/16 19:00:12 hwoarang Exp $
+
+*xplanet-1.2.2 (16 Sep 2011)
+
+ 16 Sep 2011; Markos Chandras <hwoarang@gentoo.org> +xplanet-1.2.2.ebuild:
+ Version bump. Also fixes bug #383215
08 Nov 2010; Krzysztof Pawlik <nelchael@gentoo.org> xplanet-1.2.1.ebuild:
Change dependency: media-libs/jpeg -> virtual/jpeg.
diff --git a/x11-misc/xplanet/xplanet-1.2.2.ebuild b/x11-misc/xplanet/xplanet-1.2.2.ebuild
new file mode 100644
index 000000000000..d0bdd82ff8cf
--- /dev/null
+++ b/x11-misc/xplanet/xplanet-1.2.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.2.2.ebuild,v 1.1 2011/09/16 19:00:12 hwoarang Exp $
+
+EAPI=4
+
+DESCRIPTION="a program to render images of the earth into the X root window"
+HOMEPAGE="http://xplanet.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gif jpeg X truetype tiff png"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXt
+ x11-libs/libXext )
+ gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng
+ media-libs/netpbm )
+ truetype? ( =media-libs/freetype-2*
+ x11-libs/pango )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto
+ x11-proto/scrnsaverproto )"
+
+src_configure() {
+ local myconf
+
+ use X \
+ && myconf="${myconf} --with-x --with-xscreensaver" \
+ || myconf="${myconf} --with-x=no --with-xscreensaver=no"
+
+ use gif \
+ && myconf="${myconf} --with-gif" \
+ || myconf="${myconf} --with-gif=no"
+
+ use jpeg \
+ && myconf="${myconf} --with-jpeg" \
+ || myconf="${myconf} --with-jpeg=no"
+
+ use tiff \
+ && myconf="${myconf} --with-tiff" \
+ || myconf="${myconf} --with-tiff=no"
+
+ use png \
+ && myconf="${myconf} --with-png --with-pnm" \
+ || myconf="${myconf} --with-png=no --with-pnm=no"
+
+ use truetype \
+ && myconf="${myconf} --with-freetype --with-pango" \
+ || myconf="${myconf} --with-freetype=no --with-pango=no"
+
+ econf \
+ --with-cspice=no \
+ ${myconf}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}