summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-21 12:14:51 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-21 12:14:51 +0000
commitc689ecc75f8878e2682d1524afb7318119fd16b3 (patch)
treedcb0667e673a88e12604ac9ab6d2591688e1ff49 /x11-misc/xdiskusage
parentAdd patch to fix compilation with GCC 4. See bug #146185. (diff)
downloadgentoo-2-c689ecc75f8878e2682d1524afb7318119fd16b3.tar.gz
gentoo-2-c689ecc75f8878e2682d1524afb7318119fd16b3.tar.bz2
gentoo-2-c689ecc75f8878e2682d1524afb7318119fd16b3.zip
Fix bug #135633.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'x11-misc/xdiskusage')
-rw-r--r--x11-misc/xdiskusage/ChangeLog6
-rw-r--r--x11-misc/xdiskusage/files/digest-xdiskusage-1.482
-rw-r--r--x11-misc/xdiskusage/files/xdiskusage-1.48-amd64.patch29
-rw-r--r--x11-misc/xdiskusage/xdiskusage-1.48.ebuild11
4 files changed, 46 insertions, 2 deletions
diff --git a/x11-misc/xdiskusage/ChangeLog b/x11-misc/xdiskusage/ChangeLog
index 8f9ce008b988..e6a5edd00479 100644
--- a/x11-misc/xdiskusage/ChangeLog
+++ b/x11-misc/xdiskusage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xdiskusage
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdiskusage/ChangeLog,v 1.12 2006/01/21 16:55:49 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdiskusage/ChangeLog,v 1.13 2006/09/21 12:14:51 nelchael Exp $
+
+ 21 Sep 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/xdiskusage-1.48-amd64.patch, xdiskusage-1.48.ebuild:
+ Fix bug #135633.
21 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org>
-xdiskusage-1.46.ebuild, xdiskusage-1.48.ebuild:
diff --git a/x11-misc/xdiskusage/files/digest-xdiskusage-1.48 b/x11-misc/xdiskusage/files/digest-xdiskusage-1.48
index be37ec87535b..21d8b796fa80 100644
--- a/x11-misc/xdiskusage/files/digest-xdiskusage-1.48
+++ b/x11-misc/xdiskusage/files/digest-xdiskusage-1.48
@@ -1 +1,3 @@
MD5 a902aa9d73761ade98256c3cd5c1f533 xdiskusage-1.48.tgz 37332
+RMD160 a656484c71f74a2f0a8e703954bc212e9bd86cf5 xdiskusage-1.48.tgz 37332
+SHA256 7842aa42510bf52c367164d44a977915ad9f070864d5175157738f8d6894274b xdiskusage-1.48.tgz 37332
diff --git a/x11-misc/xdiskusage/files/xdiskusage-1.48-amd64.patch b/x11-misc/xdiskusage/files/xdiskusage-1.48-amd64.patch
new file mode 100644
index 000000000000..632861b8e0a9
--- /dev/null
+++ b/x11-misc/xdiskusage/files/xdiskusage-1.48-amd64.patch
@@ -0,0 +1,29 @@
+--- xdiskusage-1.48.original/xdiskusage.C 2006-09-21 12:03:32.000000000 +0000
++++ xdiskusage-1.48/xdiskusage.C 2006-09-21 12:10:17.000000000 +0000
+@@ -510,7 +510,7 @@
+ ulong size = strtoul(buffer, &p, 10);
+ if (!isspace(*p) || p == buffer) {
+ if (!*p || *p=='#') continue; // ignore blank lines or comments (?)
+- fl_alert("%s:%d: does not look like du output: %s", path, line_no, p);
++ fl_alert("%s:%d: does not look like du output: %s", path, (int)line_no, p);
+ cancelled = 1;
+ continue;
+ }
+@@ -988,7 +988,7 @@
+ void OutputWindow::sort_cb(Fl_Widget* o, void*v) {
+ OutputWindow* d = (OutputWindow*)(o->window());
+ int (*compare)(const Node*, const Node*);
+- switch ((int)v) {
++ switch ((long int)v) {
+ case 's': compare = largestfirst; break;
+ case 'r': compare = smallestfirst; break;
+ case 'a': compare = alphabetical; break;
+@@ -1001,7 +1001,7 @@
+
+ void OutputWindow::columns_cb(Fl_Widget* o, void*v) {
+ OutputWindow* d = (OutputWindow*)(o->window());
+- int n = (int)v;
++ int n = (long int)v;
+ ::ncols = n;
+ if (n == d->ncols) return;
+ if (d->current_depth > d->root_depth+n-1) {
diff --git a/x11-misc/xdiskusage/xdiskusage-1.48.ebuild b/x11-misc/xdiskusage/xdiskusage-1.48.ebuild
index 97b8f40cae92..8422aa7192c3 100644
--- a/x11-misc/xdiskusage/xdiskusage-1.48.ebuild
+++ b/x11-misc/xdiskusage/xdiskusage-1.48.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdiskusage/xdiskusage-1.48.ebuild,v 1.4 2006/01/21 16:55:49 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdiskusage/xdiskusage-1.48.ebuild,v 1.5 2006/09/21 12:14:51 nelchael Exp $
+
+inherit eutils
DESCRIPTION="front end to xdu for viewing disk usage graphically under X11"
SRC_URI="http://xdiskusage.sourceforge.net/${P}.tgz"
@@ -14,6 +16,13 @@ IUSE=""
DEPEND="x11-libs/fltk
virtual/glut"
+src_unpack() {
+
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-amd64.patch"
+
+}
+
src_compile() {
econf || die "configure failed"