summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-09-20 14:56:14 +0000
committerSimon Stelling <blubb@gentoo.org>2006-09-20 14:56:14 +0000
commit9b0d0ded53eb4a3bbfe9dfb68c47018a95113400 (patch)
treeddbec3463ac449a37089fb881a49f9fbe95b1b6e /x11-misc/i855crt
parentRe-add call for java-pkg-opt-2_pkg_setup (diff)
downloadgentoo-2-9b0d0ded53eb4a3bbfe9dfb68c47018a95113400.tar.gz
gentoo-2-9b0d0ded53eb4a3bbfe9dfb68c47018a95113400.tar.bz2
gentoo-2-9b0d0ded53eb4a3bbfe9dfb68c47018a95113400.zip
adding a patch to support the i915 chipset
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'x11-misc/i855crt')
-rw-r--r--x11-misc/i855crt/ChangeLog8
-rw-r--r--x11-misc/i855crt/files/digest-i855crt-0.4-r13
-rw-r--r--x11-misc/i855crt/files/i855crt-i915support.diff73
-rw-r--r--x11-misc/i855crt/i855crt-0.4-r1.ebuild34
4 files changed, 117 insertions, 1 deletions
diff --git a/x11-misc/i855crt/ChangeLog b/x11-misc/i855crt/ChangeLog
index 31dd6217c75e..094b2551d7c3 100644
--- a/x11-misc/i855crt/ChangeLog
+++ b/x11-misc/i855crt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/i855crt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/i855crt/ChangeLog,v 1.5 2006/08/06 10:39:26 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i855crt/ChangeLog,v 1.6 2006/09/20 14:56:14 blubb Exp $
+
+*i855crt-0.4-r1 (20 Sep 2006)
+
+ 20 Sep 2006; <blubb@gentoo.org> +files/i855crt-i915support.diff,
+ +i855crt-0.4-r1.ebuild:
+ adding a patch to support the i915 chipset
06 Aug 2006; Simon Stelling <blubb@gentoo.org> i855crt-0.4.ebuild:
re-adding explicit RDEPEND
diff --git a/x11-misc/i855crt/files/digest-i855crt-0.4-r1 b/x11-misc/i855crt/files/digest-i855crt-0.4-r1
new file mode 100644
index 000000000000..f43aa2bee495
--- /dev/null
+++ b/x11-misc/i855crt/files/digest-i855crt-0.4-r1
@@ -0,0 +1,3 @@
+MD5 6522fa9b261be53c366ba153876fcc83 i855crt-0.4.tar.gz 65209
+RMD160 6aa715257ff120420a32bbc2ae7165f3266fc9e0 i855crt-0.4.tar.gz 65209
+SHA256 942fb0cde89737e921837d5ecab2a49158b04a5389205728cfa49108ee0bc269 i855crt-0.4.tar.gz 65209
diff --git a/x11-misc/i855crt/files/i855crt-i915support.diff b/x11-misc/i855crt/files/i855crt-i915support.diff
new file mode 100644
index 000000000000..83c9c38dd19a
--- /dev/null
+++ b/x11-misc/i855crt/files/i855crt-i915support.diff
@@ -0,0 +1,73 @@
+diff -ur ../i855-crt-0.4/dumpreg.c ./dumpreg.c
+--- ../i855-crt-0.4/dumpreg.c 2004-05-01 17:50:45.000000000 +0100
++++ ./dumpreg.c 2005-05-31 15:18:12.927156400 +0100
+@@ -36,10 +36,11 @@
+ (p = strstr(*buff_ptr, I810_DC100STR_1)) != NULL ||
+ (p = strstr(*buff_ptr, I810_DC100STR_2)) != NULL ||
+ (p = strstr(*buff_ptr, I810_IGSTR)) != NULL ||
+- (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL;
++ (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL ||
+ (p = strstr(*buff_ptr, I830STR)) != NULL ||
+ (p = strstr(*buff_ptr, I845STR)) != NULL ||
+- (p = strstr(*buff_ptr, I865STR)) != NULL ;
++ (p = strstr(*buff_ptr, I865STR)) != NULL ||
++ (p = strstr(*buff_ptr, I915STR)) != NULL ;
+
+ if(i)
+ {
+@@ -89,7 +90,7 @@
+ chip = i810_chip(&buff, &len, pci_f);
+ if (chip == NULL)
+ {
+- fprintf(stderr, "No know videocard has been found.\n");
++ fprintf(stderr, "No known videocard has been found.\n");
+ exit(1);
+ }
+ pclose(pci_f);
+diff -ur ../i855-crt-0.4/i855crt.c ./i855crt.c
+--- ../i855-crt-0.4/i855crt.c 2004-05-08 13:27:20.000000000 +0100
++++ ./i855crt.c 2005-05-31 15:17:57.100562408 +0100
+@@ -254,14 +254,15 @@
+ (p = strstr(*buff_ptr, I810_DC100STR_1)) != NULL ||
+ (p = strstr(*buff_ptr, I810_DC100STR_2)) != NULL ||
+ (p = strstr(*buff_ptr, I810_IGSTR)) != NULL ||
+- (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL;
++ (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL ||
+ (p = strstr(*buff_ptr, I830STR)) != NULL ||
+ (p = strstr(*buff_ptr, I845STR)) != NULL ||
+- (p = strstr(*buff_ptr, I865STR)) != NULL ;
++ (p = strstr(*buff_ptr, I865STR)) != NULL ||
++ (p = strstr(*buff_ptr, I915STR)) != NULL ;
+
+ if(i)
+ {
+- fprintf(stderr,"This driver is untested with your videocard !\n");
++ fprintf(stderr,"This driver is untested with your video card !\n");
+ return p;
+ }
+
+@@ -493,7 +494,7 @@
+ chip = i810_chip(&buff, &len, pci_f);
+ if (chip == NULL)
+ {
+- fprintf(stderr, "No know videocard has been found.\n");
++ fprintf(stderr, "No known videocard has been found.\n");
+ exit(1);
+ }
+ pclose(pci_f);
+diff -ur ../i855-crt-0.4/i855crt.h ./i855crt.h
+--- ../i855-crt-0.4/i855crt.h 2004-05-01 17:06:28.000000000 +0100
++++ ./i855crt.h 2005-05-31 15:07:53.232364328 +0100
+@@ -1,3 +1,4 @@
++
+ /*
+ * This is part of the source for i855crt driver
+ * copyright(c) Merello Andrea 2004
+@@ -45,6 +46,7 @@
+ #define I845STR "8086:2562"
+ #define I855STR "8086:3582"
+ #define I865STR "8086:2572"
++#define I915STR "8086:2592"
+ #define MEMSTR "Memory at"
+ #define NONPRSTR "32-bit, non-prefetchable"
+
diff --git a/x11-misc/i855crt/i855crt-0.4-r1.ebuild b/x11-misc/i855crt/i855crt-0.4-r1.ebuild
new file mode 100644
index 000000000000..549e64d6a0b3
--- /dev/null
+++ b/x11-misc/i855crt/i855crt-0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i855crt/i855crt-0.4-r1.ebuild,v 1.1 2006/09/20 14:56:14 blubb Exp $
+
+inherit eutils
+
+DESCRIPTION="Intel Montara 855GM CRT out auxiliary driver"
+HOMEPAGE="http://i855crt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXext
+ x11-libs/libXv"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-i915support.diff || die "failed to apply patch"
+
+ # upstream ships it with the binary, we want to make sure we compile it
+ make clean || die "make clean failed"
+}
+
+src_install() {
+ dobin i855crt
+ insinto /etc
+ doins i855crt.conf
+}