summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-03 06:15:40 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-03 06:15:40 +0000
commitce8b1013e675a9d7f4d88c25ad1c2b427f26e007 (patch)
tree40684d0e94d39886e22f024013d0d4b4d5d3eb65 /x11-libs
parentVersion bump. Test failure has been fixed upstream. (diff)
downloadgentoo-2-ce8b1013e675a9d7f4d88c25ad1c2b427f26e007.tar.gz
gentoo-2-ce8b1013e675a9d7f4d88c25ad1c2b427f26e007.tar.bz2
gentoo-2-ce8b1013e675a9d7f4d88c25ad1c2b427f26e007.zip
Version bump. Fix manpages regenerating. Patch reported upstream. Drop older. Force due to unsynced tree
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXi/ChangeLog10
-rw-r--r--x11-libs/libXi/files/1.3.1-0001-Add-configure-switch-for-manpages-regenerating.patch65
-rw-r--r--x11-libs/libXi/libXi-1.2.1.ebuild26
-rw-r--r--x11-libs/libXi/libXi-1.3.1.ebuild41
4 files changed, 115 insertions, 27 deletions
diff --git a/x11-libs/libXi/ChangeLog b/x11-libs/libXi/ChangeLog
index 8550a697a84e..7ba13cc9bd2e 100644
--- a/x11-libs/libXi/ChangeLog
+++ b/x11-libs/libXi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/libXi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.82 2010/08/02 18:24:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.83 2010/08/03 06:15:39 scarabeus Exp $
+
+*libXi-1.3.1 (03 Aug 2010)
+
+ 03 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> -libXi-1.2.1.ebuild,
+ +libXi-1.3.1.ebuild,
+ +files/1.3.1-0001-Add-configure-switch-for-manpages-regenerating.patch:
+ Version bump. Fix manpages regenerating. Patch reported upstream. Drop
+ older.
02 Aug 2010; Raúl Porcel <armin76@gentoo.org> libXi-1.3.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #308521
diff --git a/x11-libs/libXi/files/1.3.1-0001-Add-configure-switch-for-manpages-regenerating.patch b/x11-libs/libXi/files/1.3.1-0001-Add-configure-switch-for-manpages-regenerating.patch
new file mode 100644
index 000000000000..a774d54d9e85
--- /dev/null
+++ b/x11-libs/libXi/files/1.3.1-0001-Add-configure-switch-for-manpages-regenerating.patch
@@ -0,0 +1,65 @@
+From c6d02ef39180174896fca5a720d25f991802ef60 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Chv=C3=A1tal?= <scarabeus@gentoo.org>
+Date: Mon, 2 Aug 2010 18:23:10 +0200
+Subject: [PATCH] Add configure switch for manpages regenerating.
+
+---
+ configure.ac | 35 ++++++++++++++++++++++-------------
+ 1 files changed, 22 insertions(+), 13 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index baf10f8..423e65d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,26 +25,35 @@ AC_SUBST(XI_CFLAGS)
+ AC_SUBST(XI_LIBS)
+
+ # Check for xmlto and asciidoc for man page conversion
+-# (only needed by people building tarballs)
+-AC_ARG_VAR([XMLTO], [Path to xmlto command])
+-AC_PATH_PROG([XMLTO], [xmlto])
+-AC_ARG_VAR([ASCIIDOC], [Path to asciidoc command])
+-AC_PATH_PROG([ASCIIDOC], [asciidoc])
+-if test "x$XMLTO" = "x" && test "x$ASCIIDOC" = "x"; then
+- have_doctools=yes
++AC_ARG_WITH(manpages, AS_HELP_STRING([--with-manpages],
++ [Enable manpages building/regenerating (default: enabled if xmlto and asciidoc found)]),
++ [MANPAGES=$withval], [MANPAGES=auto])
++if test "x$MANPAGES" = "xyes" -o "x$MANPAGES" = "xauto" ; then
++ AC_ARG_VAR([XMLTO], [Path to xmlto command])
++ AC_PATH_PROG([XMLTO], [xmlto])
++ AC_ARG_VAR([ASCIIDOC], [Path to asciidoc command])
++ AC_PATH_PROG([ASCIIDOC], [asciidoc])
++ if test "x$XMLTO" != "x" && test "x$ASCIIDOC" != "x"; then
++ regen_manpages=yes
++ else
++ if test "x$MANPAGES" = "xyes"; then
++ AC_MSG_ERROR([Asciidoc or xmlto not found but manpages rebuild explicitely requested on configure line])
++ else
++ AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
++ fi
++ regen_manpages=no
++ fi
+ else
+- have_doctools=no
+-fi
+-AM_CONDITIONAL([HAVE_DOCTOOLS], [test $have_doctools = yes])
+-if test $have_doctools = no; then
+- AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
++ regen_manpages=no
++ AC_MSG_WARN([Manpage generating disabled on configure line])
+ fi
++AM_CONDITIONAL([HAVE_DOCTOOLS], [test "x$regen_manpages" = "xyes"])
+
+ # Determine if the source for man pages is available
+ # It may already be present (tarball) or can be generated using doctools
+ AM_CONDITIONAL([INSTALL_MANPAGES],
+ [test -f "$srcdir/man/XAllowDeviceEvents.man" || \
+- test $have_doctools = yes])
++ test "x$regen_manpages" = "xyes"])
+
+ XORG_CHECK_MALLOC_ZERO
+
+--
+1.7.2
+
diff --git a/x11-libs/libXi/libXi-1.2.1.ebuild b/x11-libs/libXi/libXi-1.2.1.ebuild
deleted file mode 100644
index e618cd04d10c..000000000000
--- a/x11-libs/libXi/libXi-1.2.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.2.1.ebuild,v 1.12 2009/12/15 16:10:14 armin76 Exp $
-
-# Must be before x-modular eclass is inherited
-#SNAPSHOT="yes"
-
-inherit x-modular
-
-DESCRIPTION="X.Org Xi library"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="
- >=x11-proto/inputproto-1.5
- x11-libs/libX11
- x11-libs/libXext"
-DEPEND="${RDEPEND}
- x11-proto/xproto"
-
-pkg_postinst() {
- x-modular_pkg_postinst
-
- ewarn "Some special keys and keyboard layouts may stop working."
- ewarn "To fix them, recompile xorg-server."
-}
diff --git a/x11-libs/libXi/libXi-1.3.1.ebuild b/x11-libs/libXi/libXi-1.3.1.ebuild
new file mode 100644
index 000000000000..825db8df48e6
--- /dev/null
+++ b/x11-libs/libXi/libXi-1.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.3.1.ebuild,v 1.1 2010/08/03 06:15:39 scarabeus Exp $
+
+EAPI=3
+XORG_EAUTORECONF="yes"
+inherit xorg-2
+
+DESCRIPTION="X.Org Xi library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc"
+
+RDEPEND="
+ >=x11-libs/libX11-1.3
+ >=x11-libs/libXext-1.1
+ >=x11-proto/inputproto-2.0
+"
+DEPEND="${RDEPEND}
+ >=x11-proto/xproto-7.0.16
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PV}-0001-Add-configure-switch-for-manpages-regenerating.patch" )
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ CONFIGURE_OPTIONS="
+ $(use_with doc manpages)
+ --with-manpages
+ "
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ ewarn "Some special keys and keyboard layouts may stop working."
+ ewarn "To fix them, recompile xorg-server."
+}