summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-05-30 23:27:15 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-05-30 23:27:15 +0000
commit86d6f02ae112d4139434c1a8244b954128378bbf (patch)
treea30dac4d3e1bd85ec6959adb5d8d5682ac79f9c9 /x11-libs
parentThe people cried out for color and the Gnome gods decreed that there shall be... (diff)
downloadgentoo-2-86d6f02ae112d4139434c1a8244b954128378bbf.tar.gz
gentoo-2-86d6f02ae112d4139434c1a8244b954128378bbf.tar.bz2
gentoo-2-86d6f02ae112d4139434c1a8244b954128378bbf.zip
obvious the gnome gods didn't bless me with intellegence when checking in files
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libzvt/files/digest-libzvt-1.116.11
-rw-r--r--x11-libs/libzvt/libzvt-1.116.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/libzvt/files/digest-libzvt-1.116.1 b/x11-libs/libzvt/files/digest-libzvt-1.116.1
new file mode 100644
index 000000000000..d98f2f8ad5e6
--- /dev/null
+++ b/x11-libs/libzvt/files/digest-libzvt-1.116.1
@@ -0,0 +1 @@
+MD5 896eaee04fe379e80c7005b3aeec699e libzvt-1.116.1.tar.bz2 245309
diff --git a/x11-libs/libzvt/libzvt-1.116.1.ebuild b/x11-libs/libzvt/libzvt-1.116.1.ebuild
new file mode 100644
index 000000000000..066140265c5c
--- /dev/null
+++ b/x11-libs/libzvt/libzvt-1.116.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libzvt/libzvt-1.116.1.ebuild,v 1.1 2002/05/30 23:27:15 blocke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Zed's Virtual Terminal Library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/libzvt/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=x11-libs/gtk+-2.0.0
+ >=media-libs/libart_lgpl-2.3.8-r1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc ABOUT* AUTHORS COPY* ChangeLog INSTALL NEWS README
+ docinto libzvt
+ dodoc libzvt/AUTHORS libzvt/BUGS libzvt/README libzvt/TODO
+}
+
+
+
+
+