summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-09 20:45:22 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-09 20:45:22 +0000
commit5c9316fa0f52ca616230142ea0bc0f14eac9b705 (patch)
tree3cb303576d0a4b7e70f393c1bbb057cf56356f1d /x11-libs/vte
parentStable on amd64 wrt bug #340077 (diff)
downloadgentoo-2-5c9316fa0f52ca616230142ea0bc0f14eac9b705.tar.gz
gentoo-2-5c9316fa0f52ca616230142ea0bc0f14eac9b705.tar.bz2
gentoo-2-5c9316fa0f52ca616230142ea0bc0f14eac9b705.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog12
-rw-r--r--x11-libs/vte/metadata.xml2
-rw-r--r--x11-libs/vte/vte-0.26.0.ebuild48
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 294799fd4093..72a52867e7d7 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.258 2010/10/07 20:55:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.259 2010/10/09 20:45:22 pacho Exp $
+
+*vte-0.26.0 (09 Oct 2010)
+
+ 09 Oct 2010; Pacho Ramos <pacho@gentoo.org> +vte-0.26.0.ebuild:
+ Version bump for Gnome 2.32: set terminal widget background color to
+ terminal background, fix 'Cursor invisible (plain black) in (xfce)
+ Terminal & terminator' bug, cleanup vte_terminal_determine_colors, other
+ bugfixes and translation updates. Add introspection support, update python
+ depends to work on systems with python3 as main interpreter, drop all
+ upstreamed patches.
07 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> vte-0.24.3.ebuild:
ppc64 stable wrt #324077
diff --git a/x11-libs/vte/metadata.xml b/x11-libs/vte/metadata.xml
index 84c40c2c6ea0..83b3acdab51a 100644
--- a/x11-libs/vte/metadata.xml
+++ b/x11-libs/vte/metadata.xml
@@ -4,5 +4,7 @@
<herd>gnome</herd>
<use>
<flag name='glade'>Provide integration with <pkg>dev-util/glade</pkg>.</flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>for
+ introspection</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/vte/vte-0.26.0.ebuild b/x11-libs/vte/vte-0.26.0.ebuild
new file mode 100644
index 000000000000..6dd4db37faf1
--- /dev/null
+++ b/x11-libs/vte/vte-0.26.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.26.0.ebuild,v 1.1 2010/10/09 20:45:22 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit gnome2 python
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade +introspection python"
+
+RDEPEND=">=dev-libs/glib-2.22.0
+ >=x11-libs/gtk+-2.20.0
+ >=x11-libs/pango-1.22.0
+ sys-libs/ncurses
+ glade? ( dev-util/glade:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ python? ( >=dev-python/pygtk-2.4 )
+ x11-libs/libX11
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecation
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable introspection)
+ $(use_enable python)
+ --with-html-dir=/usr/share/doc/${PF}/html
+ --with-gtk=2.0"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ use python && python_set_active_version 2
+}