summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-05 07:45:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-05 07:45:43 +0000
commit57b0cf4ee395f63075be2936382243e4a44809e4 (patch)
treef5bc6e8cc834229390ea25224b6d0c5275439822 /x11-libs/gtkscintilla2
parentfix repoman warnings (diff)
downloadgentoo-2-57b0cf4ee395f63075be2936382243e4a44809e4.tar.gz
gentoo-2-57b0cf4ee395f63075be2936382243e4a44809e4.tar.bz2
gentoo-2-57b0cf4ee395f63075be2936382243e4a44809e4.zip
Repoman warnings
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkscintilla2')
-rw-r--r--x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild22
-rw-r--r--x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild20
2 files changed, 16 insertions, 26 deletions
diff --git a/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild b/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild
index 4eaa1379d788..94471af703fc 100644
--- a/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild
+++ b/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild,v 1.6 2004/06/24 22:02:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild,v 1.7 2009/05/05 07:45:43 ssuominen Exp $
-MY_P="GtkScintilla2-${PV}"
+MY_P=GtkScintilla2-${PV}
DESCRIPTION="Gtk-2 wrappers for the Scintilla source editing components."
HOMEPAGE="http://www.gphpedit.org/"
SRC_URI="http://gphpedit.org/releases/${MY_P}.tar.gz"
@@ -13,17 +13,15 @@ KEYWORDS="x86 amd64"
LICENSE="GPL-2"
RDEPEND=">=x11-libs/gtk+-2.0"
-
DEPEND=">=dev-util/pkgconfig-0.12.0
>=dev-lang/python-2.2
${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_unpack() {
-
unpack ${A}
- cd ${S}
+ cd "${S}"
# some quick touches to the Makefile, bump the version
# and make use of our CFLAGS
@@ -32,21 +30,17 @@ src_unpack() {
-e "/CFLAGS/s/-g/${CFLAGS} -fPIC/" < Makefile.orig > Makefile
# and again, in the scintilla part
- cd ${S}/scintilla/gtk
+ cd "${S}"/scintilla/gtk
cp makefile makefile.orig
sed -e "/CXXFLAGS/s/-Os/${CFLAGS} -fPIC/" < makefile.orig > makefile
}
src_compile() {
-
emake || die
-
}
src_install() {
-
- make DESTDIR=${D} install || die
- dodoc COPYING README
-
+ make DESTDIR="${D}" install || die
+ dodoc README
}
diff --git a/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild b/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
index bc93737af0e9..034e9bd8c57e 100644
--- a/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
+++ b/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild,v 1.8 2005/11/06 10:53:13 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild,v 1.9 2009/05/05 07:45:43 ssuominen Exp $
inherit multilib
-MY_P="GtkScintilla2-${PV}"
+MY_P=GtkScintilla2-${PV}
DESCRIPTION="Gtk-2 wrappers for the Scintilla source editing components."
HOMEPAGE="http://www.gphpedit.org/"
SRC_URI="http://gphpedit.org/download/files/${MY_P}.tar.gz"
@@ -15,17 +15,15 @@ KEYWORDS="x86 amd64 ppc"
LICENSE="GPL-2"
RDEPEND=">=x11-libs/gtk+-2.0"
-
DEPEND=">=dev-util/pkgconfig-0.12.0
>=dev-lang/python-2.2
${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_unpack() {
-
unpack ${A}
- cd ${S}
+ cd "${S}"
# some quick touches to the Makefile, bump the version
# and make use of our CFLAGS
@@ -35,7 +33,7 @@ src_unpack() {
-i Makefile
# and again, in the scintilla part
- cd ${S}/scintilla/gtk
+ cd "${S}"/scintilla/gtk
sed -e "/CXXFLAGS/s/-Os/${CFLAGS} -fPIC/" -i makefile
}
@@ -45,8 +43,6 @@ src_compile() {
}
src_install() {
-
- make DESTDIR=${D} LIB_DIR=/usr/$(get_libdir) install || die
- dodoc COPYING README
-
+ make DESTDIR="${D}" LIB_DIR=/usr/$(get_libdir) install || die
+ dodoc README
}