summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-24 10:44:48 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-24 10:44:48 +0000
commitb5d5313366159a3ec4390d508f4d901befa2e8f3 (patch)
tree01c1cc5f5f8a112bf84a0d1c8609c59c60c196c0 /www-servers/webfs
parentRevert my commit as lightdm-unity-greeter requires >=valac-0.15 which we don'... (diff)
downloadgentoo-2-b5d5313366159a3ec4390d508f4d901befa2e8f3.tar.gz
gentoo-2-b5d5313366159a3ec4390d508f4d901befa2e8f3.tar.bz2
gentoo-2-b5d5313366159a3ec4390d508f4d901befa2e8f3.zip
Fix init script, bug #360547 by Joseph L.
(Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/webfs')
-rw-r--r--www-servers/webfs/ChangeLog8
-rw-r--r--www-servers/webfs/files/webfs.initd-r130
-rw-r--r--www-servers/webfs/webfs-1.21-r2.ebuild43
3 files changed, 80 insertions, 1 deletions
diff --git a/www-servers/webfs/ChangeLog b/www-servers/webfs/ChangeLog
index 7f8347c5dddf..9fa7ac0ab250 100644
--- a/www-servers/webfs/ChangeLog
+++ b/www-servers/webfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/webfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/ChangeLog,v 1.23 2012/03/21 11:37:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/ChangeLog,v 1.24 2012/03/24 10:44:48 pacho Exp $
+
+*webfs-1.21-r2 (24 Mar 2012)
+
+ 24 Mar 2012; Pacho Ramos <pacho@gentoo.org> +files/webfs.initd-r1,
+ +webfs-1.21-r2.ebuild:
+ Fix init script, bug #360547 by Joseph L.
21 Mar 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop www-server herd as discussed in gentoo-dev ML.
diff --git a/www-servers/webfs/files/webfs.initd-r1 b/www-servers/webfs/files/webfs.initd-r1
new file mode 100644
index 000000000000..43302a2c269c
--- /dev/null
+++ b/www-servers/webfs/files/webfs.initd-r1
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/files/webfs.initd-r1,v 1.1 2012/03/24 10:44:47 pacho Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ WEBFS_OPTS="-p ${WEBFS_PORT:-80} -f ${WEBFS_INDEX:-index.html} ${WEBFS_OPTS}"
+ [[ -n "${WEBFS_DOCROOT}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -r ${WEBFS_DOCROOT}"
+ [[ -n "${WEBFS_CHROOT}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -R ${WEBFS_CHROOT}"
+ [[ -n "${WEBFS_LOG}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -L ${WEBFS_LOG}"
+ [[ -n "${WEBFS_MAXCONN}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -c ${WEBFS_MAXCONN}"
+ [[ -n "${WEBFS_IPV6}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -6"
+ [[ -n "${WEBFS_SSL}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -S"
+ [[ -n "${WEBFS_SERVNAME}" ]] && WEBFS_OPTS="${WEBFS_OPTS} -n ${WEBFS_SERVNAME}"
+ [[ -n "${WEBFS_DIR_LIST}" ]] || WEBFS_OPTS="${WEBFS_OPTS} -j"
+
+ ebegin "Starting webfsd"
+ start-stop-daemon --start --quiet --exec /usr/bin/webfsd -- ${WEBFS_OPTS}
+ eend $? "Failed to start webfsd"
+}
+
+stop() {
+ ebegin "Stopping webfsd"
+ start-stop-daemon --stop --quiet --exec /usr/bin/webfsd
+ eend $? "Failed to stop webfsd"
+}
diff --git a/www-servers/webfs/webfs-1.21-r2.ebuild b/www-servers/webfs/webfs-1.21-r2.ebuild
new file mode 100644
index 000000000000..2d6eb0a9bdc1
--- /dev/null
+++ b/www-servers/webfs/webfs-1.21-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/webfs-1.21-r2.ebuild,v 1.1 2012/03/24 10:44:48 pacho Exp $
+
+inherit eutils
+
+DESCRIPTION="Lightweight HTTP server for static content"
+SRC_URI="http://dl.bytesex.org/releases/${PN}/${P}.tar.gz"
+HOMEPAGE="http://linux.bytesex.org/misc/webfs.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl threads"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/webfs-1.21-Variables.mk-dont-strip-binaries-on-install.patch"
+}
+
+src_compile() {
+ local myconf
+ use ssl || myconf="${myconf} USE_SSL=no"
+ use threads && myconf="${myconf} USE_THREADS=yes"
+
+ emake prefix=/usr ${myconf} || die "emake failed"
+}
+
+src_install() {
+ local myconf
+ use ssl || myconf="${myconf} USE_SSL=no"
+ use threads && myconf="${myconf} USE_THREADS=yes"
+ einstall ${myconf} mandir="${D}/usr/share/man" || die "make install failed"
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN} || die "newinitd failed"
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+ dodoc README
+}