summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-01-04 05:25:42 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-01-04 05:25:42 +0000
commit5070700efb594946d328385933d6c25e2194c608 (patch)
tree3e834e4f9c99f0a4b987facc82488d26f1bb81f0 /www-plugins/google-talkplugin
parentVersion bump. Remove old. (diff)
downloadgentoo-2-5070700efb594946d328385933d6c25e2194c608.tar.gz
gentoo-2-5070700efb594946d328385933d6c25e2194c608.tar.bz2
gentoo-2-5070700efb594946d328385933d6c25e2194c608.zip
add screen sharing and LINGUAS support (bug #397463)
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'www-plugins/google-talkplugin')
-rw-r--r--www-plugins/google-talkplugin/ChangeLog10
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-2.5.6.0-r1.ebuild (renamed from www-plugins/google-talkplugin/google-talkplugin-2.5.6.0.ebuild)24
2 files changed, 29 insertions, 5 deletions
diff --git a/www-plugins/google-talkplugin/ChangeLog b/www-plugins/google-talkplugin/ChangeLog
index 49e42aa9e1a7..14c3a2800a45 100644
--- a/www-plugins/google-talkplugin/ChangeLog
+++ b/www-plugins/google-talkplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/google-talkplugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/ChangeLog,v 1.19 2011/11/19 16:46:04 ottxor Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/ChangeLog,v 1.20 2012/01/04 05:25:42 ottxor Exp $
+
+*google-talkplugin-2.5.6.0-r1 (04 Jan 2012)
+
+ 04 Jan 2012; Christoph Junghans <ottxor@gentoo.org>
+ -google-talkplugin-2.5.6.0.ebuild, +google-talkplugin-2.5.6.0-r1.ebuild:
+ add screen sharing and LINGUAS support (bug #397463)
19 Nov 2011; Christoph Junghans <ottxor@gentoo.org>
-google-talkplugin-1.8.0.0.ebuild, -google-talkplugin-2.1.7.0.ebuild,
diff --git a/www-plugins/google-talkplugin/google-talkplugin-2.5.6.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-2.5.6.0-r1.ebuild
index 1e3544dc94be..2f974764fe1d 100644
--- a/www-plugins/google-talkplugin/google-talkplugin-2.5.6.0.ebuild
+++ b/www-plugins/google-talkplugin/google-talkplugin-2.5.6.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.5.6.0.ebuild,v 1.1 2011/11/19 16:41:50 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.5.6.0-r1.ebuild,v 1.1 2012/01/04 05:25:42 ottxor Exp $
EAPI=4
-inherit nsplugins
+inherit eutils nsplugins
if [ "${PV}" != "9999" ]; then
DEB_PATCH="1"
@@ -72,6 +72,14 @@ QA_DT_HASH="${INSTALL_BASE}/libnpg.*so
S="${WORKDIR}"
+LANGS="ar cs en et fr hu lt ms pl ru sv tl vi bg da fa gu id ja lv nl
+sk ta tr bn de es fi hi is kn ml no sl te uk ca el fil hr it ko mr or
+ro sr th ur"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
# nofetch means upstream bumped and thus needs version bump
pkg_nofetch() {
einfo "This version is no longer available from Google."
@@ -106,6 +114,16 @@ src_install() {
inst_plugin "/${i}"
done
+ #install screen-sharing stuff - bug #397463
+ insinto "/${INSTALL_BASE}"
+ doins "${INSTALL_BASE}"/windowpicker.glade
+
+ strip-linguas ${LANGS}
+ for l in ${LINGUAS}; do
+ insinto "/${INSTALL_BASE}"/locale/$l/LC_MESSAGES/
+ doins "${INSTALL_BASE}"/locale/$l/LC_MESSAGES/windowpicker.mo
+ done
+
#install bundled libCg
if ! use system-libCg; then
exeinto "/${INSTALL_BASE}"/lib