summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-28 18:31:50 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-28 18:31:50 +0000
commit5522387ef2b8060ee4d691b735664751e207c780 (patch)
tree0e0062c33be703ae09d32c39727c91975c257bf4 /www-client/jd
parentsys-kernel/genkernel: Bump to. 3.4.15 (diff)
downloadgentoo-2-5522387ef2b8060ee4d691b735664751e207c780.tar.gz
gentoo-2-5522387ef2b8060ee4d691b735664751e207c780.tar.bz2
gentoo-2-5522387ef2b8060ee4d691b735664751e207c780.zip
Fixed slot deps
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'www-client/jd')
-rw-r--r--www-client/jd/ChangeLog6
-rw-r--r--www-client/jd/jd-2.6.5_p100425.ebuild10
-rw-r--r--www-client/jd/jd-2.7.5_p101228.ebuild18
-rw-r--r--www-client/jd/jd-2.8.0_p110203.ebuild16
4 files changed, 25 insertions, 25 deletions
diff --git a/www-client/jd/ChangeLog b/www-client/jd/ChangeLog
index 80de7a04a25f..5dfb95289ffe 100644
--- a/www-client/jd/ChangeLog
+++ b/www-client/jd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/jd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.24 2011/02/03 00:05:50 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.25 2011/03/28 18:31:50 angelos Exp $
+
+ 28 Mar 2011; Christoph Mende <angelos@gentoo.org> jd-2.6.5_p100425.ebuild,
+ jd-2.7.5_p101228.ebuild, jd-2.8.0_p110203.ebuild:
+ Fixed slot deps
*jd-2.8.0_p110203 (03 Feb 2011)
diff --git a/www-client/jd/jd-2.6.5_p100425.ebuild b/www-client/jd/jd-2.6.5_p100425.ebuild
index 4e30b72b7a26..5323e47f1bd2 100644
--- a/www-client/jd/jd-2.6.5_p100425.ebuild
+++ b/www-client/jd/jd-2.6.5_p100425.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.6.5_p100425.ebuild,v 1.1 2010/04/30 23:46:32 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.6.5_p100425.ebuild,v 1.2 2011/03/28 18:31:50 angelos Exp $
EAPI="2"
inherit eutils autotools
@@ -17,8 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa gnome gnutls migemo"
-RDEPEND=">=dev-cpp/gtkmm-2.8
- >=dev-libs/glib-2
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
x11-misc/xdg-utils
alsa? ( >=media-libs/alsa-lib-1 )
gnome? ( >=gnome-base/libgnomeui-2 )
@@ -54,7 +54,7 @@ src_configure() {
$(use_with !gnutls openssl) \
$(use_with migemo) \
$(use_with migemo migemodict /usr/share/migemo/migemo-dict) \
- ${myconf} || die "econf failed"
+ ${myconf}
}
src_install() {
diff --git a/www-client/jd/jd-2.7.5_p101228.ebuild b/www-client/jd/jd-2.7.5_p101228.ebuild
index c66b6f312154..647102fd8416 100644
--- a/www-client/jd/jd-2.7.5_p101228.ebuild
+++ b/www-client/jd/jd-2.7.5_p101228.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.7.5_p101228.ebuild,v 1.1 2010/12/30 05:43:21 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.7.5_p101228.ebuild,v 1.2 2011/03/28 18:31:50 angelos Exp $
+EAPI=3
inherit eutils autotools
MY_P="${P/_p/-}"
@@ -16,8 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa gnome gnutls migemo"
-RDEPEND=">=dev-cpp/gtkmm-2.8
- >=dev-libs/glib-2
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
x11-misc/xdg-utils
alsa? ( >=media-libs/alsa-lib-1 )
gnome? ( >=gnome-base/libgnomeui-2 )
@@ -34,13 +35,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf="--with-xdgopen"
# use gnomeui sm instead of Xorg SM/ICE
@@ -55,8 +54,7 @@ src_compile() {
$(use_with !gnutls openssl) \
$(use_with migemo) \
$(use_with migemo migemodict /usr/share/migemo/migemo-dict) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
diff --git a/www-client/jd/jd-2.8.0_p110203.ebuild b/www-client/jd/jd-2.8.0_p110203.ebuild
index 38cad5e2ba68..cd0a55833bc8 100644
--- a/www-client/jd/jd-2.8.0_p110203.ebuild
+++ b/www-client/jd/jd-2.8.0_p110203.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.8.0_p110203.ebuild,v 1.1 2011/02/03 00:05:50 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.8.0_p110203.ebuild,v 1.2 2011/03/28 18:31:50 angelos Exp $
+EAPI=3
inherit eutils autotools
MY_P="${P/_p/-}"
@@ -16,8 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa gnome gnutls migemo"
-RDEPEND=">=dev-cpp/gtkmm-2.8
- >=dev-libs/glib-2
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
x11-misc/xdg-utils
alsa? ( >=media-libs/alsa-lib-1 )
gnome? ( >=gnome-base/libgnomeui-2 )
@@ -34,13 +35,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf="--with-xdgopen"
# use gnomeui sm instead of Xorg SM/ICE
@@ -55,8 +54,7 @@ src_compile() {
$(use_with !gnutls openssl) \
$(use_with migemo) \
$(use_with migemo migemodict /usr/share/migemo/migemo-dict) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
+ ${myconf}
}
src_install() {