summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-03 16:59:41 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-03 16:59:41 +0000
commitd73f4c9acf88a9e6579360474973333292618524 (patch)
tree267329ab233f75d01f7de9d5cfaf43da2bbbbda0 /www-apps/gnopaste
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-d73f4c9acf88a9e6579360474973333292618524.tar.gz
gentoo-2-d73f4c9acf88a9e6579360474973333292618524.tar.bz2
gentoo-2-d73f4c9acf88a9e6579360474973333292618524.zip
merge from webapps overlay wrt #208584
(Portage version: 2.1.4)
Diffstat (limited to 'www-apps/gnopaste')
-rw-r--r--www-apps/gnopaste/ChangeLog12
-rw-r--r--www-apps/gnopaste/gnopaste-0.5.5.ebuild26
2 files changed, 25 insertions, 13 deletions
diff --git a/www-apps/gnopaste/ChangeLog b/www-apps/gnopaste/ChangeLog
index 799a1decfef1..bd9c0fd7e731 100644
--- a/www-apps/gnopaste/ChangeLog
+++ b/www-apps/gnopaste/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/gnopaste
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gnopaste/ChangeLog,v 1.4 2007/07/29 17:27:15 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gnopaste/ChangeLog,v 1.5 2008/02/03 16:59:41 hollow Exp $
+
+ 03 Feb 2008; Benedikt Böhm <hollow@gentoo.org> gnopaste-0.5.5.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> gnopaste-0.5.5.ebuild:
+ Remove hard dependency on apache for Bug 208584; remove virtual/mysql
+ dependency and check for required PHP features instead. Do not install
+ subversion directories. General ebuild cleanup
29 Jul 2007; Christian Heim <phreak@gentoo.org> gnopaste-0.5.5.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to
diff --git a/www-apps/gnopaste/gnopaste-0.5.5.ebuild b/www-apps/gnopaste/gnopaste-0.5.5.ebuild
index d469014ab94f..6986e88efc51 100644
--- a/www-apps/gnopaste/gnopaste-0.5.5.ebuild
+++ b/www-apps/gnopaste/gnopaste-0.5.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gnopaste/gnopaste-0.5.5.ebuild,v 1.3 2007/07/29 17:27:15 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gnopaste/gnopaste-0.5.5.ebuild,v 1.4 2008/02/03 16:59:41 hollow Exp $
-inherit webapp
+inherit webapp depend.php
DESCRIPTION="It presents a free nopaste system like http://nopaste.info"
HOMEPAGE="http://gnopaste.sf.net/"
@@ -16,29 +16,33 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-RDEPEND="virtual/mysql
- www-servers/apache
+RDEPEND="virtual/httpd-cgi
dev-lang/php"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find . -type d -name '.svn' | xargs rm -rf {} \;
+}
+
+pkg_setup() {
+ require_php_with_use mysql
+ webapp_pkg_setup
+}
+
src_install() {
# call the eclass, to initialise the image directory for us
webapp_src_preinst
- # copy the app's main files
elog "Installing main files"
cp -r . "${D}/${MY_HTDOCSDIR}"
- # identify the configuration files that this app uses
webapp_configfile "${MY_HTDOCSDIR}/config.php"
- # identify any files and directories that need to be owned
- # by the user that the server runs under
webapp_serverowned "${MY_HTDOCSDIR}/config.php"
webapp_serverowned "${MY_HTDOCSDIR}/install.php"
- # add the post-installation instructions
webapp_postinst_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
- # all done
webapp_src_install
}