summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 05:49:26 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 05:49:26 +0000
commit615f57611e7752db629f605c01c72ce5d0dd002f (patch)
tree2464af023a7f3a47bc3eaadd38888f848840590e /sys-process
parentVersion bump. (diff)
downloadgentoo-2-615f57611e7752db629f605c01c72ce5d0dd002f.tar.gz
gentoo-2-615f57611e7752db629f605c01c72ce5d0dd002f.tar.bz2
gentoo-2-615f57611e7752db629f605c01c72ce5d0dd002f.zip
Version bump.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/ChangeLog9
-rw-r--r--sys-process/numactl/numactl-2.0.7.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index f7d911b0e1f0..b2322b614a97 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/numactl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.14 2010/08/14 00:06:16 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.15 2011/06/15 05:49:26 jer Exp $
+
+*numactl-2.0.7 (15 Jun 2011)
+
+ 15 Jun 2011; Jeroen Roovers <jer@gentoo.org> +numactl-2.0.7.ebuild:
+ Version bump.
*numactl-2.0.5 (14 Aug 2010)
diff --git a/sys-process/numactl/numactl-2.0.7.ebuild b/sys-process/numactl/numactl-2.0.7.ebuild
new file mode 100644
index 000000000000..824412778ab5
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.7.ebuild,v 1.1 2011/06/15 05:49:26 jer Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" BENCH_CFLAGS="" || die
+}
+
+src_test() {
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+}
+
+src_install() {
+ emake install prefix="${D}/usr" || die
+ # delete man pages provided by the man-pages package #238805
+ rm -rf "${D}"/usr/share/man/man[25]
+ doman *.8 || die # makefile doesnt get them all
+ dodoc README TODO CHANGES DESIGN
+ if ! use perl ; then
+ rm "${D}"/usr/bin/numastat "${D}"/usr/share/man/man8/numastat.8 || die
+ fi
+}