summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-09-18 23:36:31 +0000
committerRick Farina <zerochaos@gentoo.org>2012-09-18 23:36:31 +0000
commited9f48d01f985e455fbe7e687505c8fa591603eb (patch)
tree2832ed23e83dde8dbdc847a297599cc70b91aa17 /sys-power
parentNew snapshot. (diff)
downloadgentoo-2-ed9f48d01f985e455fbe7e687505c8fa591603eb.tar.gz
gentoo-2-ed9f48d01f985e455fbe7e687505c8fa591603eb.tar.bz2
gentoo-2-ed9f48d01f985e455fbe7e687505c8fa591603eb.zip
quiet a few useless warnings and fix live ebuild
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog6
-rw-r--r--sys-power/powertop/powertop-2.1-r1.ebuild5
-rw-r--r--sys-power/powertop/powertop-9999.ebuild78
3 files changed, 66 insertions, 23 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index 0c45bdaf91f8..e1996277e87c 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.66 2012/09/17 05:14:49 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.67 2012/09/18 23:36:31 zerochaos Exp $
+
+ 18 Sep 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild,
+ powertop-9999.ebuild:
+ quiet a few useless warnings and fix live ebuild
17 Sep 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild:
reorder a few things, hopefully this is safer and avoids env pollution
diff --git a/sys-power/powertop/powertop-2.1-r1.ebuild b/sys-power/powertop/powertop-2.1-r1.ebuild
index 28ff2f3b4c10..09941db161d7 100644
--- a/sys-power/powertop/powertop-2.1-r1.ebuild
+++ b/sys-power/powertop/powertop-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.6 2012/09/17 05:14:49 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.7 2012/09/18 23:36:31 zerochaos Exp $
EAPI="4"
@@ -39,7 +39,6 @@ RDEPEND="
DOCS=( TODO README )
pkg_setup() {
- einfo "Warning: enabling all suggested kconfig params may have performance impacts"
linux_config_exists
CONFIG_CHECK="
~X86_MSR
@@ -59,10 +58,8 @@ pkg_setup() {
~TRACING
"
linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
- einfo "Below are likely critical failures:"
ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
- einfo "Below are warnings only, however bugs may be ignored if you don't enable full support in the kernel:"
ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 0fba0114984a..214545827d10 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.12 2012/06/01 17:42:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.13 2012/09/18 23:36:31 zerochaos Exp $
EAPI="4"
-inherit eutils
+inherit eutils linux-info
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
- inherit git-2
+ inherit git-2 autotools
SRC_URI=""
else
- SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.bz2"
+ SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
@@ -19,24 +19,73 @@ HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="unicode"
+IUSE="unicode X"
-DEPEND="
- dev-libs/libnl
+COMMON_DEPEND="
+ dev-libs/libnl:3
sys-apps/pciutils
sys-devel/gettext
sys-libs/ncurses[unicode?]
- sys-libs/zlib
+"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
"
RDEPEND="
- ${DEPEND}
- x11-apps/xset
+ ${COMMON_DEPEND}
+ X? ( x11-apps/xset )
"
DOCS=( TODO README )
+pkg_setup() {
+ linux_config_exists
+ CONFIG_CHECK="
+ ~X86_MSR
+ ~DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~USB_SUSPEND
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
+ ~TIMER_STATS
+ ~EVENT_POWER_TRACING_DEPRECATED
+ ~TRACING
+ "
+ linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+
src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw no)
+ export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
default
}
@@ -44,10 +93,3 @@ src_install() {
default
keepdir /var/cache/powertop
}
-
-pkg_postinst() {
- echo
- einfo "For PowerTOP to work best, use a Linux kernel with the"
- einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
- echo
-}