summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-09-07 23:11:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-09-07 23:11:29 +0000
commit5edf54c312f172a0dc5598ed7d76efa9d8fcf08c (patch)
tree14dab476feacb692ad57898abe7415f983e073b9 /sys-power
parentStable for x86, wrt bug #433223 (diff)
downloadgentoo-2-5edf54c312f172a0dc5598ed7d76efa9d8fcf08c.tar.gz
gentoo-2-5edf54c312f172a0dc5598ed7d76efa9d8fcf08c.tar.bz2
gentoo-2-5edf54c312f172a0dc5598ed7d76efa9d8fcf08c.zip
Bug #415693: version bump.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/iasl/ChangeLog9
-rw-r--r--sys-power/iasl/files/iasl-20120816-locale.patch15
-rw-r--r--sys-power/iasl/iasl-20120816.ebuild124
3 files changed, 146 insertions, 2 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 7440ecea25d6..3cd22bd6f571 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.38 2012/04/26 16:38:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.39 2012/09/07 23:11:29 robbat2 Exp $
+
+*iasl-20120816 (07 Sep 2012)
+
+ 07 Sep 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/iasl-20120816-locale.patch, +iasl-20120816.ebuild:
+ Bug #415693: version bump.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> iasl-20111123.ebuild:
keyword ~amd64-fbsd
@@ -177,4 +183,3 @@
13 May 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+iasl-20050309.ebuild:
Initial commit. Based on ebuild by Micheal <michi2k@web.de>, bug #52511.
-
diff --git a/sys-power/iasl/files/iasl-20120816-locale.patch b/sys-power/iasl/files/iasl-20120816-locale.patch
new file mode 100644
index 000000000000..425513342105
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20120816-locale.patch
@@ -0,0 +1,15 @@
+diff -Nuar acpica-unix-20120816.orig/generate/unix/Makefile.config acpica-unix-20120816/generate/unix/Makefile.config
+--- acpica-unix-20120816.orig/generate/unix/Makefile.config 2012-08-16 15:51:15.000000000 +0000
++++ acpica-unix-20120816/generate/unix/Makefile.config 2012-09-07 18:31:41.887229126 +0000
+@@ -161,9 +161,9 @@
+ #YACC= byacc
+ #YFLAGS += -v -d
+ #
+-YACC= bison
++YACC= LC_ALL=C bison
+ YFLAGS += -v -d -y
+
+-LEX= flex
++LEX= LC_ALL=C flex
+ LFLAGS += -i -s
+
diff --git a/sys-power/iasl/iasl-20120816.ebuild b/sys-power/iasl/iasl-20120816.ebuild
new file mode 100644
index 000000000000..b76d0335b97c
--- /dev/null
+++ b/sys-power/iasl/iasl-20120816.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20120816.ebuild,v 1.1 2012/09/07 23:11:29 robbat2 Exp $
+
+EAPI=4
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+MY_TESTS_P=${MY_PN/ca/tests}-${PV}
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="https://www.acpica.org/downloads/index.php"
+SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
+ test? ( http://www.acpica.org/download/${MY_TESTS_P}.tar.gz )"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use test && has test ${FEATURES}; then
+ ewarn 'You have selected USE="test". This will install the test results'
+ ewarn "into /usr/share/${PF}/, compressed as a tarball."
+ ewarn 'The tests themselves will only rarely die, but the test results'
+ ewarn 'are interesting for arch testing. The tests may take quite some'
+ ewarn 'time to complete.'
+ fi
+}
+
+src_prepare() {
+ #epatch "${FILESDIR}/${PN}-20110922-as-needed.patch"
+ epatch "${FILESDIR}/${PN}-20120816-locale.patch"
+ # Upstream has changed the buildsystem a lot, not sure if these are still
+ # needed
+ #epatch "${FILESDIR}/${PN}-20120816-parallelmake-001.patch"
+ #epatch "${FILESDIR}/${PN}-20110922-parallelmake-002.patch"
+ #epatch "${FILESDIR}/${PN}-20110922-parallelmake-003.patch"
+
+ find "${S}" -type f -name 'Makefile*' -print0 | \
+ xargs -0 -I '{}' \
+ sed -r -e 's:-\<Werror\>::g' -i '{}' \
+ || die
+
+ export BITS=64
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ cd acpica/generate/unix
+ emake BITS=${BITS}
+}
+
+src_test() {
+ aslts_test
+ #aapits_test
+ #The aapits test currently fails, missing include probably.
+}
+
+src_install() {
+ cd acpica/generate/unix
+ emake install DESTDIR="${D}" BITS=${BITS}
+ default_src_install
+ #local bin
+ #for bin in $(<"${T}"/binlist) ; do
+ # dobin "${T}"/${bin}
+ #done
+ dodoc "${S}"/changes.txt
+ newdoc "${S}"/source/compiler/readme.txt compiler-readme.txt
+ newdoc "${S}"/generate/unix/readme.txt unix-readme.txt
+ newdoc "${S}"/generate/lint/readme.txt lint-readme.txt
+ newdoc "${S}"/source/compiler/new_table.txt compiler-new_table.txt
+
+ if use test && has test ${FEATURES}; then
+ tb="${T}"/testresults.tar.bz2
+ export ASLTSDIR="$(<"${T}"/asltdir)"
+ ebegin "Creating Test Tarball"
+ tar -cjf "${tb}" -C "${ASLTSDIR}"/tmp/RESULTS . || die "tar failed"
+ eend $?
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ doins ${tb} || die "doins testresults.tar.bz2 failed"
+ fi
+
+}
+
+aslts_test() {
+ export ASL="${S}"/generate/unix/bin${BITS}/iasl \
+ acpiexec="${S}"/generate/unix/bin${BITS}/acpiexec \
+ ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
+ export PATH="${PATH}:${ASLTSDIR}/bin"
+ echo "$ASLTSDIR" >"${T}"/asltdir
+ cd "${ASLTSDIR}"
+ edos2unix $(find . -type 'f')
+ make install || die "make install aslts test failed"
+ chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
+
+ #The below Do commands runs the tests twice and then dies if the results aren't
+ #Identical.
+ Do 1 || die "failed Do 1"
+ Do 2 || die "failed Do 2"
+}
+
+aapits_test() {
+ mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
+ cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
+ edos2unix $(find . -type 'f')
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+ make || die "make in aapits failed"
+ cd asl || die "cd asl failed"
+ make || die "make in asl failed"
+ cd ../bin
+ ./aapitsrun || die "aapitsrun failed"
+}