summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-27 11:56:44 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-27 11:56:44 +0000
commit06e2790e23bc241a527a00e5e8faa0b6821d46df (patch)
tree07bed7b29daaabab19967b32c6e595748908fe92 /sys-power/bbswitch
parentVersion bump, drop old. (diff)
downloadgentoo-2-06e2790e23bc241a527a00e5e8faa0b6821d46df.tar.gz
gentoo-2-06e2790e23bc241a527a00e5e8faa0b6821d46df.tar.bz2
gentoo-2-06e2790e23bc241a527a00e5e8faa0b6821d46df.zip
Version bump fixing kernel-3.6 regression, bug #439384 by Michele Ciacci.
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-power/bbswitch')
-rw-r--r--sys-power/bbswitch/ChangeLog8
-rw-r--r--sys-power/bbswitch/bbswitch-0.5.ebuild36
2 files changed, 42 insertions, 2 deletions
diff --git a/sys-power/bbswitch/ChangeLog b/sys-power/bbswitch/ChangeLog
index 85a877e82400..d2b48da35d16 100644
--- a/sys-power/bbswitch/ChangeLog
+++ b/sys-power/bbswitch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/bbswitch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/ChangeLog,v 1.4 2012/06/04 19:36:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/ChangeLog,v 1.5 2012/10/27 11:56:44 pacho Exp $
+
+*bbswitch-0.5 (27 Oct 2012)
+
+ 27 Oct 2012; Pacho Ramos <pacho@gentoo.org> +bbswitch-0.5.ebuild:
+ Version bump fixing kernel-3.6 regression, bug #439384 by Michele Ciacci.
04 Jun 2012; Pacho Ramos <pacho@gentoo.org> -bbswitch-0.4.1.ebuild,
metadata.xml:
@@ -20,4 +25,3 @@
+files/bbswitch.modprobe, +metadata.xml:
Initial commit from bumblebee overlay, this fixes bug #384083. Thanks a lot to
mva and rei4dan for their work.
-
diff --git a/sys-power/bbswitch/bbswitch-0.5.ebuild b/sys-power/bbswitch/bbswitch-0.5.ebuild
new file mode 100644
index 000000000000..be2eb49bffa8
--- /dev/null
+++ b/sys-power/bbswitch/bbswitch-0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/bbswitch-0.5.ebuild,v 1.1 2012/10/27 11:56:44 pacho Exp $
+
+EAPI="4"
+inherit linux-mod
+
+DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+SRC_URI="mirror://github/Bumblebee-Project/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/linux-sources
+ sys-kernel/linux-headers"
+RDEPEND=""
+
+MODULE_NAMES="bbswitch(acpi)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="default"
+ BUILD_PARAMS="KVERSION=${KV_FULL}"
+}
+
+src_install() {
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
+ dodoc NEWS
+
+ linux-mod_src_install
+}