summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-19 21:19:11 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-19 21:19:11 +0000
commitdfca76b7b14f7c57f1c3b8409c92596da102bf46 (patch)
tree94a5147397804b1108dfdc88a6a987d6593a913b /sys-libs/uclibc
parentStable sparc, x86. (diff)
downloadgentoo-2-dfca76b7b14f7c57f1c3b8409c92596da102bf46.tar.gz
gentoo-2-dfca76b7b14f7c57f1c3b8409c92596da102bf46.tar.bz2
gentoo-2-dfca76b7b14f7c57f1c3b8409c92596da102bf46.zip
dont hardcode sys-libs CATEGORY
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.27-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
index 502b86f847a3..8867e2a9888c 100644
--- a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.1 2005/06/18 06:12:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.2 2005/06/19 21:19:11 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -74,12 +74,12 @@ alt_rprefix() {
}
pkg_setup() {
- if ! built_with_use sys-libs/uclibc nls && use nls && ! use pregen ; then
+ if ! built_with_use ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
eerror "You previously built uclibc with USE=-nls."
eerror "You cannot generate locale data with this"
eerror "system. Please rerun emerge with USE=pregen."
die "host cannot support locales"
- elif built_with_use sys-libs/uclibc nls && ! use nls ; then
+ elif built_with_use ${CATEGORY}/uclibc nls && ! use nls ; then
eerror "You previously built uclibc with USE=nls."
eerror "Rebuilding uClibc with USE=-nls will prob"
eerror "destroy your system."