summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-04-25 18:50:52 +0000
committerSven Vermeulen <swift@gentoo.org>2013-04-25 18:50:52 +0000
commita764eb42933e3c07017eaf37314f000cfa8826c6 (patch)
tree439ef1dad9551994887c997b62a1c7f9350f4c2d /sys-libs/libsepol
parentFix autoreconf failures with automake-1.13 (bug #467010). (diff)
downloadgentoo-2-a764eb42933e3c07017eaf37314f000cfa8826c6.tar.gz
gentoo-2-a764eb42933e3c07017eaf37314f000cfa8826c6.tar.bz2
gentoo-2-a764eb42933e3c07017eaf37314f000cfa8826c6.zip
New upstream release
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/ChangeLog9
-rw-r--r--sys-libs/libsepol/libsepol-2.1.9-r1.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index aab956864ce1..81fe4f480d90 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.54 2012/12/30 15:19:13 swift Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.55 2013/04/25 18:50:52 swift Exp $
+
+*libsepol-2.1.9-r1 (25 Apr 2013)
+
+ 25 Apr 2013; Sven Vermeulen <swift@gentoo.org> +libsepol-2.1.9-r1.ebuild:
+ New upstream release
30 Dec 2012; Sven Vermeulen libsepol-2.1.8-r1.ebuild:
Stabilize
diff --git a/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild b/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild
new file mode 100644
index 000000000000..7981c31831ef
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild,v 1.1 2013/04/25 18:50:52 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20130423/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+
+ epatch_user
+}
+
+src_compile() {
+ tc-export RANLIB;
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}