summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-30 23:36:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-30 23:36:35 +0000
commit88c0cb93c97591128af629e972611be598f5d58c (patch)
treeb5d14a5b2da7567a6bfd26ae4720af43940cbedf /sys-libs/libcxx
parentstop hacking around unwind headers and install them protected under libcxxrt ... (diff)
downloadgentoo-2-88c0cb93c97591128af629e972611be598f5d58c.tar.gz
gentoo-2-88c0cb93c97591128af629e972611be598f5d58c.tar.bz2
gentoo-2-88c0cb93c97591128af629e972611be598f5d58c.zip
use upstream documented way for building on top of libcxxrt
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog5
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild16
2 files changed, 16 insertions, 5 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 3e4ada5b7bde..c3fc2d7eafa9 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.14 2013/05/30 23:21:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.15 2013/05/30 23:36:35 aballier Exp $
+
+ 30 May 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
+ use upstream documented way for building on top of libcxxrt
30 May 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
add a static-libs useflag and link tests with -lm
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 95db05dda4fb..3fc9275fd968 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.7 2013/05/30 23:21:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.8 2013/05/30 23:36:35 aballier Exp $
EAPI=5
@@ -27,7 +27,7 @@ else
fi
IUSE="static-libs"
-RDEPEND="sys-libs/libcxxrt[static-libs?]"
+RDEPEND=">=sys-libs/libcxxrt-0.0_p20130530[static-libs?]"
DEPEND="${RDEPEND}
sys-devel/clang
app-arch/xz-utils"
@@ -41,12 +41,20 @@ src_prepare() {
}
src_configure() {
- append-cppflags "-I/usr/include/libcxxrt -DLIBCXXRT"
# Needs to be built with clang. gcc-4.6.3 fails at least.
# TODO: cross-compile ?
export CC=clang
export CXX=clang++
- use static-libs && BUILD_DIR="${S}_static" mycmakeargs="-DLIBCXX_ENABLE_SHARED=OFF" cmake-utils_src_configure
+
+ local mycmakeargs_base=(
+ -DLIBCXX_CXX_ABI=libcxxrt
+ -DLIBCXX_LIBCXXRT_INCLUDE_PATHS="/usr/include/libcxxrt/"
+ )
+ if use static-libs ; then
+ local mycmakeargs=( "${mycmakeargs_base[@]}" "-DLIBCXX_ENABLE_SHARED=OFF" )
+ BUILD_DIR="${S}_static" cmake-utils_src_configure
+ fi
+ local mycmakeargs=( "${mycmakeargs_base[@]}" )
BUILD_DIR="${S}_shared" cmake-utils_src_configure
}