summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-06-05 15:16:03 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-06-05 15:16:03 +0000
commit4da106350c43846cabc28aa598bd1fe83102de16 (patch)
tree309d264f5fab34efbc6ea2fa46029c997f70d693 /sys-fs
parentStable for x86 (diff)
downloadgentoo-2-4da106350c43846cabc28aa598bd1fe83102de16.tar.gz
gentoo-2-4da106350c43846cabc28aa598bd1fe83102de16.tar.bz2
gentoo-2-4da106350c43846cabc28aa598bd1fe83102de16.zip
Fixup libdirs for multilib.
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog6
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index 0c550def36b9..a5feaae40496 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.30 2006/06/01 23:35:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.31 2006/06/05 15:16:03 chutzpah Exp $
+
+ 05 Jun 2006; Patrick McLean <chutzpah@gentoo.org>
+ cryptsetup-luks-1.0.3-r2.ebuild:
+ Fixup libdirs for multilib.
01 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
cryptsetup-luks-1.0.3-r2.ebuild:
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
index 34362fd9ab6b..6ff5d3aba167 100644
--- a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild,v 1.2 2006/06/01 23:35:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild,v 1.3 2006/06/05 15:16:03 chutzpah Exp $
-inherit autotools linux-info eutils flag-o-matic
+inherit autotools linux-info eutils flag-o-matic multilib
DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
HOMEPAGE="http://luks.endorphin.org/"
@@ -63,12 +63,12 @@ src_compile() {
ewarn "If you need cryptsetup for an initrd or initramfs then you"
ewarn "should NOT use the dynamic USE flag"
epause 5
- econf --sbindir=/bin --disable-static "${PIC_FLAG}" \
+ econf --sbindir=/bin --disable-static --libdir=/usr/$(get_libdir) "${PIC_FLAG}" \
$(use_enable nls) \
$(use_enable selinux) \
|| die
else
- econf --sbindir=/bin --enable-static "${PIC_FLAG}" \
+ econf --sbindir=/bin --enable-static --libdir=/usr/$(get_libdir) "${PIC_FLAG}" \
$(use_enable nls) \
$(use_enable selinux) \
|| die
@@ -79,7 +79,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "install failed"
- rmdir "${D}/usr/lib/cryptsetup"
+ rmdir "${D}/usr/$(get_libdir)/cryptsetup"
insinto /lib/rcscripts/addons
newconfd ${FILESDIR}/cryptfs.confd cryptfs
doins "${FILESDIR}"/dm-crypt-{start,stop}.sh