summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-08 14:00:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-08 14:00:42 +0000
commit2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450 (patch)
treee6bce4ea52824f9e4783bf617faa69e51bbf2496 /sys-fs/xfsdump
parentuse net instead of need net in init.d script (Manifest recommit) (diff)
downloadgentoo-2-2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450.tar.gz
gentoo-2-2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450.tar.bz2
gentoo-2-2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450.zip
ver bump bump buuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuump
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog7
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.241
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.24.ebuild55
3 files changed, 62 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 7e2ea7c5abc6..86c76e8dd6d1 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.13 2004/08/31 10:50:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.14 2004/10/08 14:00:42 vapier Exp $
+
+*xfsdump-2.2.24 (08 Oct 2004)
+
+ 08 Oct 2004; Mike Frysinger <vapier@gentoo.org> +xfsdump-2.2.24.ebuild:
+ Version bump.
*xfsdump-2.2.21 (31 Aug 2004)
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.24 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.24
new file mode 100644
index 000000000000..379259d3702f
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.24
@@ -0,0 +1 @@
+MD5 4933f0a2c9c32ae97070b0e48b855df6 xfsdump-2.2.24.src.tar.gz 589786
diff --git a/sys-fs/xfsdump/xfsdump-2.2.24.ebuild b/sys-fs/xfsdump/xfsdump-2.2.24.ebuild
new file mode 100644
index 000000000000..be444f71811d
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.24.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.24.ebuild,v 1.1 2004/10/08 14:00:42 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE="debug static"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ sys-apps/attr"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ -e '/^PKG_[A-Z]*_DIR/s:= := $(DESTDIR):' \
+ include/builddefs.in \
+ || die
+}
+
+src_compile() {
+ if use debug; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ # Some archs need the PLATFORM var unset
+ unset PLATFORM
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dosym ../../sbin/xfsrestore /usr/bin/xfsrestore
+ dosym ../../sbin/xfsdump /usr/bin/xfsdump
+}