summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-07-23 09:44:28 +0000
committerTim Harder <radhermit@gentoo.org>2012-07-23 09:44:28 +0000
commitac4662e5a23dcc362021fab64529217993e2a45b (patch)
treefefb3a41f8f6d40dd760ccacf13e48fe93ff133d /sys-fs/ecryptfs-utils
parentVersion bump (diff)
downloadgentoo-2-ac4662e5a23dcc362021fab64529217993e2a45b.tar.gz
gentoo-2-ac4662e5a23dcc362021fab64529217993e2a45b.tar.bz2
gentoo-2-ac4662e5a23dcc362021fab64529217993e2a45b.zip
Respect CPPFLAGS when python and gpg support is enabled (bug #424601).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog6
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild7
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-99-python-m4.patch11
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 23d920e3072d..b6d490468ed8 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.47 2012/07/16 06:23:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.48 2012/07/23 09:44:28 radhermit Exp $
+
+ 23 Jul 2012; Tim Harder <radhermit@gentoo.org> ecryptfs-utils-99.ebuild,
+ +files/ecryptfs-utils-99-python-m4.patch:
+ Respect CPPFLAGS when python and gpg support is enabled (bug #424601).
*ecryptfs-utils-99 (16 Jul 2012)
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild
index 0303ba21922e..c6d175b21fce 100644
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild,v 1.1 2012/07/16 06:23:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-99.ebuild,v 1.2 2012/07/23 09:44:28 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
-inherit flag-o-matic pam python linux-info autotools
+inherit flag-o-matic pam python linux-info autotools eutils
DESCRIPTION="eCryptfs userspace utilities"
HOMEPAGE="https://launchpad.net/ecryptfs"
@@ -49,6 +49,9 @@ src_prepare() {
# Python bindings are built/installed manually.
sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.am || die "sed failed"
+ # respect CPPFLAGS when python support is enabled (bug #424601)
+ epatch "${FILESDIR}"/${P}-python-m4.patch
+
eautoreconf
}
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-99-python-m4.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-99-python-m4.patch
new file mode 100644
index 000000000000..05fb5fb6d796
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-99-python-m4.patch
@@ -0,0 +1,11 @@
+--- ecryptfs-utils-99/m4/ac_python_devel.m4
++++ ecryptfs-utils-99/m4/ac_python_devel.m4
+@@ -158,6 +158,8 @@
+ AC_MSG_CHECKING([consistency of all components of python development environment])
+ AC_LANG_PUSH([C])
+ # save current global flags
++ ac_save_LIBS="$LIBS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
+ LIBS="$ac_save_LIBS $PYTHON_LDFLAGS"
+ CPPFLAGS="$ac_save_CPPFLAGS $PYTHON_CPPFLAGS"
+ AC_TRY_LINK([