summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-24 06:47:30 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-24 06:47:30 +0000
commitb3a0f458f6bea40bd5edfccd478e375b7bf4d860 (patch)
tree5575344236dafaaeba4c4574cea37a5fbd9833a0 /sys-fs/dazuko
parentStop supporting Xorg 7.0. (diff)
downloadgentoo-2-b3a0f458f6bea40bd5edfccd478e375b7bf4d860.tar.gz
gentoo-2-b3a0f458f6bea40bd5edfccd478e375b7bf4d860.tar.bz2
gentoo-2-b3a0f458f6bea40bd5edfccd478e375b7bf4d860.zip
Cleanup
(Portage version: 2.1.2-r3)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog7
-rw-r--r--sys-fs/dazuko/dazuko-2.1.0.ebuild56
-rw-r--r--sys-fs/dazuko/dazuko-2.1.1.ebuild56
-rw-r--r--sys-fs/dazuko/dazuko-2.2.0.ebuild56
-rw-r--r--sys-fs/dazuko/dazuko-2.3.1-r1.ebuild54
-rw-r--r--sys-fs/dazuko/dazuko-2.3.1.ebuild50
-rw-r--r--sys-fs/dazuko/dazuko-2.3.2-r2.ebuild87
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.1.03
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.1.13
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.2.03
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.13
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.1-r13
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.2-r26
13 files changed, 6 insertions, 381 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 811ba1ae32a9..f1bf0e698c34 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.18 2007/01/19 19:31:09 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.19 2007/01/24 06:47:30 alonbl Exp $
+
+ 24 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> -dazuko-2.1.0.ebuild,
+ -dazuko-2.1.1.ebuild, -dazuko-2.2.0.ebuild, -dazuko-2.3.1.ebuild,
+ -dazuko-2.3.1-r1.ebuild, -dazuko-2.3.2-r2.ebuild:
+ Cleanup
*dazuko-2.3.3_pre1 (19 Jan 2007)
diff --git a/sys-fs/dazuko/dazuko-2.1.0.ebuild b/sys-fs/dazuko/dazuko-2.1.0.ebuild
deleted file mode 100644
index df7635d4e40b..000000000000
--- a/sys-fs/dazuko/dazuko-2.1.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.1.0.ebuild,v 1.1 2005/09/09 20:42:37 wschlich Exp $
-
-inherit linux-mod eutils
-
-DESCRIPTION="Linux kernel module and interface providing file access control"
-MY_P="${P/_/-}" # for -preN versions
-SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
-HOMEPAGE="http://www.dazuko.org"
-LICENSE="GPL-2 BSD"
-# use full kernel version as SLOT, preventing removal of dazuko
-# modules for previously used kernels
-SLOT="${KV_FULL:-0}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND=">=virtual/linux-sources-2.2"
-S="${WORKDIR}/${MY_P}"
-
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
-# TODO add 'example' USE flag, install example source code
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- ./configure \
- --kernelsrcdir="${KERNEL_DIR}" \
- || die "configure failed"
- convert_to_m Makefile
- linux-mod_src_compile
-
- cd library && emake && cd ..
-}
-
-src_install() {
- linux-mod_src_install
-
- dolib.a library/libdazuko.a
- insinto /usr/include
- doins dazukoio.h
-
- dodoc COPYING
- dodoc README
- dodoc README.linux26
- dodoc README.trusted
-# dodoc LICENSE.BSD
-# dodoc LICENSE.GPL
-}
-
diff --git a/sys-fs/dazuko/dazuko-2.1.1.ebuild b/sys-fs/dazuko/dazuko-2.1.1.ebuild
deleted file mode 100644
index 36be7421a357..000000000000
--- a/sys-fs/dazuko/dazuko-2.1.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.1.1.ebuild,v 1.1 2006/01/24 16:48:32 wschlich Exp $
-
-inherit linux-mod eutils
-
-DESCRIPTION="Linux kernel module and interface providing file access control"
-MY_P="${P/_/-}" # for -preN versions
-SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
-HOMEPAGE="http://www.dazuko.org"
-LICENSE="GPL-2 BSD"
-# use full kernel version as SLOT, preventing removal of dazuko
-# modules for previously used kernels
-SLOT="${KV_FULL:-0}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND=">=virtual/linux-sources-2.2"
-S="${WORKDIR}/${MY_P}"
-
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
-# TODO add 'example' USE flag, install example source code
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- ./configure \
- --kernelsrcdir="${KERNEL_DIR}" \
- || die "configure failed"
- convert_to_m Makefile
- linux-mod_src_compile
-
- cd library && emake && cd ..
-}
-
-src_install() {
- linux-mod_src_install
-
- dolib.a library/libdazuko.a
- insinto /usr/include
- doins dazukoio.h
-
- dodoc COPYING
- dodoc README
- dodoc README.linux26
- dodoc README.trusted
-# dodoc LICENSE.BSD
-# dodoc LICENSE.GPL
-}
-
diff --git a/sys-fs/dazuko/dazuko-2.2.0.ebuild b/sys-fs/dazuko/dazuko-2.2.0.ebuild
deleted file mode 100644
index 14c564197435..000000000000
--- a/sys-fs/dazuko/dazuko-2.2.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.2.0.ebuild,v 1.1 2006/02/19 10:59:45 wschlich Exp $
-
-inherit linux-mod eutils
-
-DESCRIPTION="Linux kernel module and interface providing file access control"
-MY_P="${P/_/-}" # for -preN versions
-SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
-HOMEPAGE="http://www.dazuko.org"
-LICENSE="GPL-2 BSD"
-# use full kernel version as SLOT, preventing removal of dazuko
-# modules for previously used kernels
-SLOT="${KV_FULL:-0}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND=">=virtual/linux-sources-2.2"
-S="${WORKDIR}/${MY_P}"
-
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
-# TODO add 'example' USE flag, install example source code
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- ./configure \
- --kernelsrcdir="${KERNEL_DIR}" \
- || die "configure failed"
- convert_to_m Makefile
- linux-mod_src_compile
-
- cd library && emake && cd ..
-}
-
-src_install() {
- linux-mod_src_install
-
- dolib.a library/libdazuko.a
- insinto /usr/include
- doins dazukoio.h
-
- dodoc COPYING
- dodoc README
- dodoc README.linux26
- dodoc README.trusted
-# dodoc LICENSE.BSD
-# dodoc LICENSE.GPL
-}
-
diff --git a/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild b/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild
deleted file mode 100644
index 604d8c0eab02..000000000000
--- a/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild,v 1.1 2006/11/08 18:41:51 alonbl Exp $
-
-inherit linux-mod
-
-DESCRIPTION="Linux kernel module and interface providing file access control"
-MY_P="${P/_/-}" # for -preN versions
-SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
-HOMEPAGE="http://www.dazuko.org"
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-DEPEND=">=virtual/linux-sources-2.2"
-S="${WORKDIR}/${MY_P}"
-
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-suspend2.patch"
-}
-
-src_compile() {
- ./configure \
- --without-dep \
- --kernelsrcdir="${KERNEL_DIR}" \
- || die "configure failed"
- convert_to_m Makefile
- linux-mod_src_compile
-
- cd library
- emake || die
- cd ..
-}
-
-src_install() {
- linux-mod_src_install
-
- dolib.a library/libdazuko.a
- insinto /usr/include
- doins dazukoio.h
-
- dodoc COPYING
- dodoc README
- dodoc README.linux26
- dodoc README.trusted
-}
-
diff --git a/sys-fs/dazuko/dazuko-2.3.1.ebuild b/sys-fs/dazuko/dazuko-2.3.1.ebuild
deleted file mode 100644
index de13a9ae1c65..000000000000
--- a/sys-fs/dazuko/dazuko-2.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.1.ebuild,v 1.4 2006/10/21 19:48:07 kloeri Exp $
-
-inherit linux-mod
-
-DESCRIPTION="Linux kernel module and interface providing file access control"
-MY_P="${P/_/-}" # for -preN versions
-SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
-HOMEPAGE="http://www.dazuko.org"
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-DEPEND=">=virtual/linux-sources-2.2"
-S="${WORKDIR}/${MY_P}"
-
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
-src_compile() {
- cd "${S}"
-
- ./configure \
- --without-dep \
- --kernelsrcdir="${KERNEL_DIR}" \
- || die "configure failed"
- convert_to_m Makefile
- linux-mod_src_compile
-
- cd library
- emake || die
- cd ..
-}
-
-src_install() {
- linux-mod_src_install
-
- dolib.a library/libdazuko.a
- insinto /usr/include
- doins dazukoio.h
-
- dodoc COPYING
- dodoc README
- dodoc README.linux26
- dodoc README.trusted
-}
-
diff --git a/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild b/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild
deleted file mode 100644
index a460e8d4ffc2..000000000000
--- a/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild,v 1.3 2006/12/20 19:44:13 alonbl Exp $
-inherit linux-mod toolchain-funcs flag-o-matic
-
-DESCRIPTION="Linux kernel module and interface providing file access control"
-MY_P="${P/_/-}" # for -preN versions
-SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz
- mirror://gentoo/${P}-linux-2.6.19.patch.bz2"
-HOMEPAGE="http://www.dazuko.org"
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
-RDEPEND=${DEPEND}
-S="${WORKDIR}/${MY_P}"
-
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
-pkg_setup() {
- [ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-2.3.1-suspend2.patch"
-
- if [ "${KERNEL}" == "linux" ] && kernel_is 2 6 19; then
- epatch "${WORKDIR}/${P}-linux-2.6.19.patch"
- fi
-}
-
-src_compile() {
- if [ "${KERNEL}" = "FreeBSD" ]; then
- KERNEL_DIR=/usr/src/sys
- KBUILD_OUTPUT=/boot/modules
- MAKE=make
- fi
- ./configure \
- --without-dep \
- --kernelsrcdir="${KERNEL_DIR}" \
- --kernelobjdir="${KBUILD_OUTPUT}" \
- || die "configure failed"
-
- if [ "${KERNEL}" = "linux" ]; then
- convert_to_m Makefile
- linux-mod_src_compile
- else
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" || die
- fi
-
- emake -C library CC="$(tc-getCC)" || die
-}
-
-src_install() {
- if [ "${KERNEL}" = "linux" ]; then
- linux-mod_src_install
- else
- insinto /boot/modules
- doins "${S}"/dazuko.kld
- exeinto /boot/modules
- doexe "${S}"/dazuko.ko
- fi
-
- dolib.a library/libdazuko.a
- insinto /usr/include
- doins dazukoio.h
-
- dodoc COPYING
- dodoc README
- dodoc README.linux26
- dodoc README.trusted
-}
-
-pkg_postinst() {
- [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst
-}
-
-pkg_postrm() {
- [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postrm
-}
-
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.1.0 b/sys-fs/dazuko/files/digest-dazuko-2.1.0
deleted file mode 100644
index 534b0782cdec..000000000000
--- a/sys-fs/dazuko/files/digest-dazuko-2.1.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 f7e5ea23a0b3a1539bd0c0b96df426f0 dazuko-2.1.0.tar.gz 159456
-RMD160 b8088797d54ce2241c7e430995c0397bd74e1e90 dazuko-2.1.0.tar.gz 159456
-SHA256 95a672346e85062b06e855efeaed38cf161f8fce8ee9081958fd7acb1fb7f517 dazuko-2.1.0.tar.gz 159456
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.1.1 b/sys-fs/dazuko/files/digest-dazuko-2.1.1
deleted file mode 100644
index 3c045912dace..000000000000
--- a/sys-fs/dazuko/files/digest-dazuko-2.1.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 35ff694434dedb25fe43dad8db4eb943 dazuko-2.1.1.tar.gz 162359
-RMD160 ecb837180a3d59c91c6938763ce7edbdc496b348 dazuko-2.1.1.tar.gz 162359
-SHA256 120a967d446d552ad485f6197f5c9d9cd8b5369ae74104c98641c8e3492031ce dazuko-2.1.1.tar.gz 162359
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.2.0 b/sys-fs/dazuko/files/digest-dazuko-2.2.0
deleted file mode 100644
index 128fa61f705c..000000000000
--- a/sys-fs/dazuko/files/digest-dazuko-2.2.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 bbe7651888d9904fb6c82fdb02331d82 dazuko-2.2.0.tar.gz 162903
-RMD160 0e1b85e4185a97590d19036d5c217c4d70247aff dazuko-2.2.0.tar.gz 162903
-SHA256 7bf51cefb36a1c572ed16bd4c184087a3903afb88fa8faee8bba22b8c4de29df dazuko-2.2.0.tar.gz 162903
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.1 b/sys-fs/dazuko/files/digest-dazuko-2.3.1
deleted file mode 100644
index 4478b3fc29d0..000000000000
--- a/sys-fs/dazuko/files/digest-dazuko-2.3.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 7f8373d4b429a9e454aa556a8f2e40fb dazuko-2.3.1.tar.gz 176944
-RMD160 cc527bf0f251cfa96ec79ddbcc8e6ad49247dbef dazuko-2.3.1.tar.gz 176944
-SHA256 9481875699e6fefd80f40b945159df55815408f76f9fd511656c55a52499fc8e dazuko-2.3.1.tar.gz 176944
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.1-r1 b/sys-fs/dazuko/files/digest-dazuko-2.3.1-r1
deleted file mode 100644
index 4478b3fc29d0..000000000000
--- a/sys-fs/dazuko/files/digest-dazuko-2.3.1-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 7f8373d4b429a9e454aa556a8f2e40fb dazuko-2.3.1.tar.gz 176944
-RMD160 cc527bf0f251cfa96ec79ddbcc8e6ad49247dbef dazuko-2.3.1.tar.gz 176944
-SHA256 9481875699e6fefd80f40b945159df55815408f76f9fd511656c55a52499fc8e dazuko-2.3.1.tar.gz 176944
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.2-r2 b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r2
deleted file mode 100644
index fee1e7bfde35..000000000000
--- a/sys-fs/dazuko/files/digest-dazuko-2.3.2-r2
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 e82799830e44dc2b5dfc9d355bcc5b2e dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
-RMD160 09a635922d364f73e6f32787397e3657d2ec8087 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
-SHA256 239c514ddb4345d758706c50c286b125d3e35e476931bec0909bdf15c80c8d06 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
-MD5 bb32e24ad60a31dbfc419d3341287f68 dazuko-2.3.2.tar.gz 177134
-RMD160 57fd3dd45a61609a18829467966657ef658ed500 dazuko-2.3.2.tar.gz 177134
-SHA256 b396fc344cf1bad0d7dfb6675573a8ca189f34867fe1256c7f31c8ec9aab45bb dazuko-2.3.2.tar.gz 177134