summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-04 13:10:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-04 13:10:02 +0000
commitb5f9b23aaa8156358d4d0ec4b58849be1234b1b5 (patch)
tree2edb9830468618a4b37115683ab6a4539ce7a960 /sys-freebsd
parentInstall GeoLiteCity.dat (bug #455340 by nandhp). (diff)
downloadgentoo-2-b5f9b23aaa8156358d4d0ec4b58849be1234b1b5.tar.gz
gentoo-2-b5f9b23aaa8156358d4d0ec4b58849be1234b1b5.tar.bz2
gentoo-2-b5f9b23aaa8156358d4d0ec4b58849be1234b1b5.zip
always pass -isystem when not bootstrapping, should fix #444920
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog5
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 010fa9776748..24abbabfa52a 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.168 2013/01/27 22:19:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.169 2013/02/04 13:10:02 aballier Exp $
+
+ 04 Feb 2013; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.1.ebuild:
+ always pass -isystem when not bootstrapping, should fix #444920
27 Jan 2013; Alexis Ballier <aballier@gentoo.org>
-freebsd-lib-9.1_rc1.ebuild, -freebsd-lib-9.1_rc2.ebuild,
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild
index 7d50ad5124a3..538287b1f3b4 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild,v 1.1 2013/01/27 21:25:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1.ebuild,v 1.2 2013/02/04 13:10:02 aballier Exp $
EAPI=2
@@ -298,7 +298,13 @@ do_bootstrap() {
do_compile() {
export MAKEOBJDIRPREFIX="${WORKDIR}/${CHOST}"
mkdir "${MAKEOBJDIRPREFIX}" || die "Could not create ${MAKEOBJDIRPREFIX}."
- need_bootstrap && do_bootstrap
+ # Bootstrap if needed, otherwise assume the system headers are in
+ # /usr/include.
+ if need_bootstrap ; then
+ do_bootstrap
+ else
+ CFLAGS="${CFLAGS} -isystem /usr/include"
+ fi
export RAW_LDFLAGS=$(raw-ldflags)