summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-14 18:35:00 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-14 18:35:00 +0000
commit2ce19f8d2199d977a1166c0a16fe1e4d4d312355 (patch)
tree7f1736f1d937c80a44f4c5eb977243cff5000d31 /sys-devel
parentRemoved dup install of man page #9083 (diff)
downloadgentoo-2-2ce19f8d2199d977a1166c0a16fe1e4d4d312355.tar.gz
gentoo-2-2ce19f8d2199d977a1166c0a16fe1e4d4d312355.tar.bz2
gentoo-2-2ce19f8d2199d977a1166c0a16fe1e4d4d312355.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog9
-rw-r--r--sys-devel/binutils/binutils-2.13.90.0.10.ebuild140
-rw-r--r--sys-devel/binutils/binutils-2.13.90.0.8.ebuild4
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.13.90.0.101
4 files changed, 151 insertions, 3 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index a6e4cf6bd502..5dfd68b483c2 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.13 2002/10/10 19:21:21 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.14 2002/10/14 18:35:00 azarah Exp $
+
+*binutils-2.13.90.0.10 (14 Oct 2002)
+
+ 14 Oct 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Version update. Remove sparc until further testing
+ from Seemant.
*binutils-2.13.90.0.8 (10 Oct 2002)
diff --git a/sys-devel/binutils/binutils-2.13.90.0.10.ebuild b/sys-devel/binutils/binutils-2.13.90.0.10.ebuild
new file mode 100644
index 000000000000..d9e8ec160244
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.13.90.0.10.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.10.ebuild,v 1.1 2002/10/14 18:35:00 azarah Exp $
+
+IUSE="nls bootstrap static build"
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+inherit libtool flag-o-matic
+
+# Generate borked binaries. Bug #6730
+filter-flags "-fomit-frame-pointer"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/devel/binutils/test/${P}.tar.bz2"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+
+SLOT="0"
+LICENSE="GPL-2|LGPL-2"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.21
+ nls? ( sys-devel/gettext )
+ || ( sys-devel/perl
+ ( !build? ( sys-devel/perl ) )
+ ( !bootstrap? ( sys-devel/perl ) )
+ )"
+# This is a hairy one. Basically depend on sys-devel/perl
+# if "build" or "bootstrap" not in USE.
+
+
+src_compile() {
+
+ local myconf=""
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+ # Fix /usr/lib/libbfd.la
+ elibtoolize --portage
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ make headers -C bfd CFLAGS=-O || die
+ emake -e LDFLAGS=-all-static || die
+ else
+ make headers -C bfd CFLAGS=-O || die
+ emake || die
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ if [ -z "`use bootstrap`" ]
+ then
+ #nuke the manpages to recreate them (only use this if we have perl)
+ find . -name '*.1' -exec rm -f {} \; || :
+ fi
+ #make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ insinto /usr/include
+ doins include/libiberty.h
+
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ #but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
+ # /usr/bin/strip we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ # The strip symlink gets created in the loop below
+
+ # By default ar, as, ld, nm, ranlib and strip are in two places; create
+ # symlinks. This will reduce the size of the tbz2 significantly. We also
+ # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
+ # appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x=""
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv ${x} ../${CHOST}/bin/${x}
+ else
+ rm -f ${x}
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ # Install pre-generated manpages .. currently we do not ...
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
+
diff --git a/sys-devel/binutils/binutils-2.13.90.0.8.ebuild b/sys-devel/binutils/binutils-2.13.90.0.8.ebuild
index 10aafa7864f0..83252766c0c8 100644
--- a/sys-devel/binutils/binutils-2.13.90.0.8.ebuild
+++ b/sys-devel/binutils/binutils-2.13.90.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.8.ebuild,v 1.1 2002/10/10 19:21:21 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.8.ebuild,v 1.2 2002/10/14 18:35:00 azarah Exp $
IUSE="nls bootstrap static build"
@@ -20,7 +20,7 @@ HOMEPAGE="http://sources.redhat.com/binutils/"
SLOT="0"
LICENSE="GPL-2|LGPL-2"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
DEPEND="virtual/glibc
>=sys-apps/portage-2.0.21
diff --git a/sys-devel/binutils/files/digest-binutils-2.13.90.0.10 b/sys-devel/binutils/files/digest-binutils-2.13.90.0.10
new file mode 100644
index 000000000000..533c76ba9f2d
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.13.90.0.10
@@ -0,0 +1 @@
+MD5 933630e61144e4ba0cd0a2b335a714cd binutils-2.13.90.0.10.tar.bz2 9607092