summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-02-19 19:37:57 +0000
committerFabian Groffen <grobian@gentoo.org>2012-02-19 19:37:57 +0000
commit07720689ed9865394b3d5a614e277e458c74c3c8 (patch)
tree9cb1c238d8b4b13a8a22e3b18ab2a4184099b835 /sys-devel
parentUse append-cflags instead of too generic append-flags to avoid F77 and FC rej... (diff)
downloadgentoo-2-07720689ed9865394b3d5a614e277e458c74c3c8.tar.gz
gentoo-2-07720689ed9865394b3d5a614e277e458c74c3c8.tar.bz2
gentoo-2-07720689ed9865394b3d5a614e277e458c74c3c8.zip
Use append-cppflags instead of too generic append-flags to avoid F77 and FC rejected warnings
(Portage version: 2.2.01.20239-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-apple/ChangeLog6
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.2.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index 267b836402a3..1d8cfed1bcf9 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/binutils-apple
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.27 2012/02/06 12:15:22 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.28 2012/02/19 19:37:57 grobian Exp $
+
+ 19 Feb 2012; Fabian Groffen <grobian@gentoo.org> binutils-apple-4.2.ebuild:
+ Use append-cppflags instead of too generic append-flags to avoid F77 and FC
+ rejected warnings
06 Feb 2012; Fabian Groffen <grobian@gentoo.org>
+files/ld64-127.2-ppc-range-warning.patch, binutils-apple-4.2.ebuild:
diff --git a/sys-devel/binutils-apple/binutils-apple-4.2.ebuild b/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
index 4a4959299411..e838cf42fa7d 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.2.ebuild,v 1.4 2012/02/06 12:15:22 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.2.ebuild,v 1.5 2012/02/19 19:37:57 grobian Exp $
EAPI="3"
@@ -154,16 +154,16 @@ src_prepare() {
src_configure() {
tc-export CC CXX AR
if use lto ; then
- append-flags -DLTO_SUPPORT
+ append-cppflags -DLTO_SUPPORT
append-ldflags -L"${EPREFIX}"/usr/$(get_libdir)/llvm
append-libs LTO
LTO=1
else
- append-flags -ULTO_SUPPORT
+ append-cppflags -ULTO_SUPPORT
LTO=0
fi
- append-flags -DNDEBUG
- append-flags -I${WORKDIR}/libunwind/include
+ append-cppflags -DNDEBUG
+ append-cppflags -I${WORKDIR}/libunwind/include
}
compile_libunwind() {